Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Wordpress 3.42 and Vanilla 2 Forums Integration

Hej,

i know this has been discussed here a few times, but i cant get it working. I installed the Vanilla plugin in Vanilla and installed the wordpress plugin.

Wordpress:
http://community.netigate.net

Vanilla
http://community.netigate.net/answers

When i try to set up the url to the vanilla forum (see above), i always get "Couldn't find a Vanilla Forum at this url :/". Curl is enabled. the url stays saved in the field though. What am i doing wrong? i have read here in the forum that as long as the url is saved it doesnt matter that much, but here it does. nothing works - no widget or no forum at http://community.netigate.de/discussions/

any ideas?

I am using:
Wordpress 3.42
Vanilla 2.0.18.4,

Comments

  • close, was a host problem, resolving ip adresses.

  • well you changed, but the problem was you didn't include the div so there is was nowhere for the iframe to be inserted.

    You have removed the page now. The iframe did exist but it wasn't inserted into the body.

    grep is your friend.

  • netigatenetigate New
    edited November 2012

    yeh, shows now that the url is varified.

    hmm..i just use the wordpress standard theme at http://community.netigate.net/discussions/ . shouldnt be shown the forum anyways even if the embed tag is within a div?

    <div id="main"><script type="text/javascript" src="http://community.netigate.net/answers/js/embed.js"></script> </div>

    well, it doenst matter for me, since i am not planning to use this functionality due to seo reasons, but there seems to be something else wrong. i want to use the comment integration of vanilla on wordpress. when i use any demo page like at http://community.netigate.net/pagetest/ i get the following error message:

    Fatal error: Class 'DOMDocument' not found in /var/www/html/community/answers/library/core/functions.general.php on line 751

    in the html output comes this:

    <div id="vanilla-comments"></div> <script type="text/javascript"> var vanilla_forum_url = 'http://community.netigate.net/answers/'; // Required: the full http url & path to your vanilla forum var vanilla_identifier = '31'; // Required: your unique identifier for the content being commented on var vanilla_url = 'http://community.netigate.net/pagetest/'; // Current page's url var vanilla_category_id = '9'; // Embed comments in this category (function() { var vanilla = document.createElement('script'); vanilla.type = 'text/javascript'; var timestamp = new Date().getTime(); vanilla.src = vanilla_forum_url + '/js/embed.js'; (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(vanilla); })(); </script> <noscript>Please enable JavaScript to view the <a href="http://vanillaforums.com/?ref_noscript">comments powered by Vanilla.</a></noscript> <div class="vanilla-credit"> <a class="vanilla-anchor" href="http://vanillaforums.com">Comments by <span class="vanilla-logo">Vanilla</span></a></div>

    do you guys have experience with this kind of error?

Sign In or Register to comment.