Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla Database Got Hacked-Need To Remove from Site

An 'older' Vanilla database got hacked, and I need to remove it from a site. Via FTP, I have deleted most of the files in the forum directory, but I cannot delete about 30 files and a few directories (gives me "550 Delete operation failed" error message). I'm assuming they are 'live' files. Can someone help me 'turn off' these files, so I can remove the forum from the site?



  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Get FileZilla it's free if the problem has afected your host they may be blocking your accesses contact your host

  • businessdadbusinessdad Stealth contributor MVP

    I don't think you can't delete them because they are "live". There is no such thing in PHP scripts, files are not permanently running. I reckon that, whatever script the hacker used, he must have changed the permissions to read only. You should connect via SSH to finish the job, or try to change them via your FTP client (not all of them support it, though).

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited December 2012

    You know, my site was compromised due to a generic php form I never finished in the cgi bin. It was harmless but could be exploited and was reported to cert and my site was pulled offline . I could not get in to erase it nor could I from ftp.They recommended FileZilla, worked real good though to erase anything remotely once my host unblocked access. But first I had to contact my host so they could unblock access to my root.

    Even if the hackers changed permissions, your host can reverse them for you. What you can do meanwhile is upload via ftp empty files with the same name as the ones you want to kill and check overwrite. If you can overwrite, you can delete.

    Make sure that you are accessing the correct directory to delete, and that you set write_enable=YES

  • Thank you for your responses. I used "CyberDuck" [like FileZilla, but on the Mac] to try to delete the files, which when I get info on them, have UNIX permissions of 755, and the "owner" has read, write, and execute privileges checked. I tried to change the connection to "FTP-SSL" and "SFTP" (SSH), but it then didn't allow me to connect ("network error, connection failed" and "I/O error").

  • peregrineperegrine MVP
    edited December 2012

    I tried to change the connection to "FTP-SSL" and "SFTP" (SSH), but it then didn't allow me to connect ("network error, connection failed" and "I/O error").

    doesn't cyberduck allow you to change owner and permissions without sftp and ftp-ssl. Or Get your provider to change the owner, permissions, and or delete.
    Sounds like you host provider has some odd things going on with the ownership of files.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    From what I found , many people have the same problem using cyberduck, just google "can't delete files using cyberduck" and see for yourself. FileZilla (it's free) can be downloaded for any system. I am on a mac too.

    You may need to delete each individual file and not the whole directory.

  • @NeedHelp you can always access using File Manager inside Cpanel, im sure that's the best way and fastest way to delete files, i used to have hacker issues ,what i did is i used cloudflare.

  • FYI: The host company ("") does not allow its customers to login using SSH, so that's why I couldn't delete the files. [They did do it for me]. Thank you all for your help!

Sign In or Register to comment.