Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

400 Bad Request when trying to use VF for WP comments

mcbentonmcbenton New
edited December 2012 in Vanilla 2.0 - 2.8

I'm using the VF plugin for WP (version info below) and attempting to use VF to handle comments on my website (http://252s13.umatter2.us). The comment form does not appear on my posts and pages. The AJAX request that is supposed to get the comments and comment form returns a 400 Bad Request response. The query parameters being submitted are, for example:

p: /vanilla/discussion/embed/

vanilla_discussion_id: 0

vanilla_identifier: 38

vanilla_type: page

vanilla_url: http://252s13.umatter2.us/2012/12/06/comments-testing/

vanilla_category_id: uncategorized

sso: eyJ1bmlxdWVpZCI6MSwibmFtZSI6Ik1vcmdhbiBCZW50b24iLCJlbWFpbCI6Im1vcmdhbkBidXJuaW5nbWluZHByb2plY3Qub3JnIiwicGhvdG91cmwiOiJodHRwOlwvXC8wLmdyYXZhdGFyLmNvbVwvYXZhdGFyXC8yYmUyOGRhY2ZiOTA2MDI3MjAyNGJhOGQ3NTdjMTc1Zj9zPTk2JmQ9aHR0cCUzQSUyRiUyRjAuZ3JhdmF0YXIuY29tJTJGYXZhdGFyJTJGYWQ1MTY1MDNhMTFjZDVjYTQzNWFjYzliYjY1MjM1MzYlM0ZzJTNEOTYmcj1HIiwid3Bfbm9uY2UiOiJlNTBlNzRkZWQ5Iiwicm9sZXMiOiJhZG1pbmlzdHJhdG9yIiwiY2xpZW50X2lkIjoiMjUyczEzIn0= cb80a35ee144279c512af54cb4b4e144e1ae9236 1354888322 hmacsha1

It appears to be causing an error on the server side. Attached is a screen shot of the html that gets returned from the ajax request.

Any ideas on how to troubleshoot this?

Using:
WP 3.4.2
VF 2.1a33
VF Plugin for WP 1.1.14
PageLines Vanilla 1.0

Comments

  • Options

    After much googling, I finally solved this issue by enabling debugging in the Vanilla config file and then following the stack trace to find the offending code. It turns out that the problem was caused by the FileUpload plugin. The version on the VF Addons site is 1.5.2, but the version in GitHub is 1.7.0. Updating to the latest version solved the problem.

    Incidentally, I also found a couple of other plugins (QnA and Voting) where the GitHub version was newer.

    I'm not sure why the version on the Addons site is not the latest version from GitHub. The versions on GitHub appear to be stable, but perhaps I'll find otherwise after some trial and error.

Sign In or Register to comment.