Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.

Problem in Basic Registration*

OFEKXOFEKX New
edited January 2013 in Localization

Hello to you all,
I am a real newbe in vanilla, and just finished installing it and changing local (hebrew) and moving everything RTL, and also embeding it to my wordpress...

everything works but the registration!
when I try to register as a new member, and I fill in all the form, when I try to hit the sign-in key I get the "Terms Of Service" window, when I close it and try again, the same Terms Of Service window pops up again, and again... Ad infinitum.

I also noticed that if a mark the box "remember my computer" it also pops up the freaking "Terms of service"!

please, I need your help!(~:

any advice on the subject will very appreciated!

michael

Comments

  • peregrineperegrine MVP
    edited December 2012

    in /conf/config.php

    try changing

    $Configuration['Garden']['SignIn']['Popup'] = TRUE;

    to

    $Configuration['Garden']['SignIn']['Popup'] = FALSE;

    if you don't see the line add it

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • thank you for your reply!

    I did as you suggested, I found the line in the config-defaults.php, changed it... and it didnt work )~:
    the dammed "term of service" window still wont let me sign-in, it's like the form doesn't get that i mark the agree for the TOS check box, and it just keeps popping up because of that...

    or maybe it has something to do with the fact that it is a translated version of vanilla..??

    any more tip??

  • peregrineperegrine MVP
    edited December 2012

    any more tip??

    yes re-read my instructions - you didn't follow them. I don't know if it will solve your problem - but you didn't follow the instructions.

    config.php

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I forgot to say That I tried it in the config.php before, did exactly as you said, and it didn't work. I saw a smiler line in config-defaults.php like the one you wrote, so I supposed you meant that config...

    I am new to this, but I am pretty sure I have done as you instructed
    I didn't find the line in config.php, so I added it as you said.. and placed it in the $Configuration['Garden'] row.. should I place it a different place? (excuse my coding ignorance, i am a real novice in these stuff)

    thanks again!

  • peregrineperegrine MVP
    edited December 2012

    no problem.

    theoretically,

    $Configuration['Garden']['SignIn']['Popup'] = FALSE;

    should have made the pop-up window turn into a regular page.

    You could try numerous things, re-install, try a different version (not sure which one you are using), disable all your plugins, change to the default theme without localization and see if you have the same problem. Reduce everything to its simplest and add more complexity to see what breaks it.

    Perhaps - it is wordpress embedding that is giving you the problem - also try non-embedded and see if it works. You've got alot of "complexities" (according to what you describe ) added to your site - it is pretty hard to determine what may be the issue unless you simplify.

    I believe you can also turn off terms of service in your dahboard - I can't recall.

    Best I can suggest.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited December 2012

    @OFEKX Can you right click the sign in button to open the sign in sheet in it's own page? Can you post a link to your site? I can read hebrew in case that is an issue, mostly would like to experience the error and be able to diagnose the problem better rather than just guess.

    I think it has to do with the embed into Wordpress like peregrine says. There is a problem with ssl encryption on WP and installations coming from a non encrypted source.

  • thank you peregrine!, I will start to reduce things and see if it works, will let you know...

    vrijvlinder, do you mean if I can "open in new tab" yes off course, just tried it... didn't change anything )`:

    the link to the embedded site:
    www.ofek-sky.com/בדיקה/

    the link to the forum itself:
    www.ofek-sky.com/forum

    try to register, and you will see you cant bypass the annoying TOS window :0
    hope you can direct me to a solution

    thank you all for your help, it is very very appreciated!

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited December 2012

    @OFEKX ok I tested the google sign in that works, then I tried the registration, It appears that just closing the terms form is not taken as an ok, and it gets stuck in a loop. it may be due to a faulty query popup javascript. Try disabling the captcha .

    it may also be the settings for the registration form. It seems to work somewhat like it knew I had just registered with the same address and gave warning, so the communication aspect of the registration is working which makes me think it could be misalignment causing the links to be on top of each other on that part of the form. It is possible that the alignment of the links in the box are touching. Even though it looks like they are not because it is hebrew, the coding for the positioning may be wrong for the box. I come up with hair brain ideas but sometimes it hit the nail on the head so don't laugh yet... I would like if you could, to change some css code for the form and see if the links get fixed.

    Find this

     body.Entry {
    text-align: center;
    }
    

    and change it to

    body.Entry {
    text-align:right;
    }
    

    upon further examination ,I think You have a live link on the page, making the whole form a link to the terms of service.
    did you put it there? that has to be removed /a is making the whole form a link so anywhere you click it takes you to the terms of service.

    image

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    There really is a problem link that did not close or was input too many times...Wherever that is it must be removed that is the only problem .

  • vrijvlinder, thank you so much fro your efforts!

    yes I know that the google sign works, but the regular registration is much more important for me, many of my student don't have gmail.

    yes, it is stuck in a loop!! how frustrating )~:

    I realigned the text to the right, as you have suggested, in the dashboard/design/style.css but it didn't work...

    I think you are on to something with the bottom of the box being a live link , when I put my cursor on the sign button, it shows the "http://ofek-sky.com/forum/dashboard/home/termsofservice" ...

    I didn't do that, at least not intentionally :) i never messed with the css of this box.

    is their any way of bypassing, changing it?

    I have no clue on where and what to look for...

    thanks again!!!!

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited December 2012

    Yea you can't mess up like that with css .... I actually closed the tags proper using Firebug browser extension to see if that would uncover the register button and it did.
    That is the problem. You may be able to get them to not reveal by using css to block them from working.

    Not sure if it will work but you can try, add this to your custom.css

    ul li a#TermsOfService‪.Popup{
    display:none!important
    }
    this usually gets rid of elements and it should banish all those links. I am sure you don't need the terms to show but you still should put a page with the terms somewhere, it is a requirement to have terms.

    the file to edit is in themes/yourtheme/custom.css not in the dashboard/design/style.css that is the main design you should not edit there. you are using embed friendly so the file to edit is in the embed friendly folder. If there is no custom.css just make one and add it to the folder. The custom.css will override the style.css

    Keep in mind that this solution is just a bandaid for a larger problem that may surface in the future with other forms. Or runaway links.

  • vrijvlinder,

    I think I have found the problem!

    it is in the translation file site_core.php in the lines:

    $Definition['I agree to the terms of service'] = 'אני מסכים לתנאי השירות

    < במונחים של שירות ';

    if I delete the class="popup" in the first line then the the submit button regains its function, and all seem to work, but the line "agree to the terms" is not translated to hebrew

    any clues as to what change i need to do in order to fix these lines so that the translation will stay but, discard the link from possessing the bottom of the form??

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited December 2012

    The thing is a definition is just that a change of words, There should not be a link like that in that line because a word is just a word. But you have a link attached to the definition. Maybe the way the link is entered is missing a tag or something.

    You have multiple links there, Getting rid of the hebrew is the same as not displaying them at all.There is a tag in the wrong place.Try this if you are feeling adventurous.But replace the [ ] with <> or the tags it had before

    $Definition['I agree to the terms of service'] = '[אני מסכים לתנאי השירות במונחים של שירות
    http://vanillaforums.org/discussion/22329/%s ]';

    You did not notice that the stuff you posted actually has a link eh? but it is badly put. Make sure the tags are closed properly. It should work again if all is fixed but if not try the css I offered and get rid of those links and just put in another one to the page of terms directly anywhere you want.

    ps the one you posted has the link embedded mine won't show in the 'terms of service' but the idea is to change where the link starts and ends. But this does not explain the multiple links there.

  • thank you again!
    I have just seen that what I posted where the links and not the codes for them...
    I tried what you suggested and the line didn't get translated, probably because it has changed from the original (with the link) so I did my best at seeing that the translation with the link is correct, thier where a couple of little things not in the right place, after allot of testing it worked!!

    $Definition['I agree to the terms of service'] = 'אני מסכים לתנאי השירות';

    now the check box is translated with the link, and the link doesn't expend for the 'remember this computer' and the 'submit' button!

    that was a real snag, I cant believe it is solved(~:

    next mission is to translate the TOS, but not soon ...

    thank you for your time and effort!

    by the way, are you israeli??

    vrijvlinder
  • I dont know how to put the lines without showing the links, so I captured the codes in an image:

    image

    vrijvlinder
  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited December 2012

    @OFEKX Oh good that you fixed it, eise yofi !, maybe the person who worked on the hebrew localization made a mistake... I think it's funny how Occam's Razor applies to this stuff, the simplest explanation is the correct one. and here we were thinking $Configure and java when it was just a badly written link !

    Here at Vanilla we are forced to learn all languages...haha not quite,I am not Israeli but lived there for two years in a boarding school many years ago.

    locate1manheare
  • I have this problem in persian language.

Sign In or Register to comment.