Please upgrade here. These earlier versions are no longer being updated and have security issues.

zipped files are password protected

This discussion is related to the File Upload Detect addon.

I've downloaded the zip file and am attempting to extract the files. Using 7-zip it gives me an error on 299 files of 'cannot open output file'. I have also tried to extract with the default Windows unzip program and it tells me that the files are password protected. Where can I find this password? Or can you upload a version that is not password protected?

Comments

  • It isn't

    try using

    http://www.zipeg.com/

    Unfortunately proprietary software can't read valid zip files sometimes.

    It was zipped using zip, you can’t get closer to the true form than that.

    grep is your friend.

  • I finally was able to find someone at my organization that could open the file. Unfortunately I am unable to use zipeg because of Java version conflicts with other programs that we use. Thanks for the suggestion though. I hope this extension ends up being what I need it to be.

    While I understand your beef with the proprietary zip programs, It honestly shouldn't be such a problem for people to simply unzip your extension. When almost every comment is about just unzipping the files then it seems more like a problem with how they were originally zipped in the first place.

  • I used a trick when extracting it using 7-zip. Open the file with 7-zip and 'drag' the 'FileUpload' directory from the actual archive.
    Maybe it has so much troubles, because there is a file called 'FileUpload' in the archive and a directory called 'FileUpload'. I don't know. At least it worked for me :-)

  • GaryFunkGaryFunk Senior Application Developer ✭✭
    edited January 2013

    The uploader has used zip compression method that is not standard.

  • x00x00 MVP
    edited January 2013

    How so? All my plugins are zipped the same way, this is the only one with this issue.

    I suggest it is an issue opening large/rich files. It might be the fact there is an icon library included. I may not include it next time.

    Only some people are having issues with opening it too. Not necessarily the majority.

    Put it this way there is a standard way of indicating password protection, this doesn't have password protection, so the software is using an arbitrary means of detecting password protection, false positive.

    grep is your friend.

  • Btw I have actually tried the zipping by other method before, it doesn’t make a difference.

    grep is your friend.

Sign In or Register to comment.