Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Solved] After upload to host server, if I change anything (language), I get a Bonk error*

S3rgioS3rgio New
edited January 2013 in Vanilla 2.0 - 2.8

Hello
I have a problem with my forum: (
When I install it and customize it in "localhost", everything works fine.
When upload to a server (I've tried hostinger and 000webhost), I get an error

"Bonk Something funky happened. Please bear with us while we iron out the kinks"

I tried to upload it without changing anything (as is the default, without customizing anything), and it works!
But if you change anything, I get error!
I would like to change the language to Spanish, but when I do, I get error!
Has anyone else had this problem?
Anyone know what could be the problem?
Thank you very much and please excuse my English

Tagged:

Comments

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @S3rgio

    See here to change the Bonk to a detailed error report.

    Then post what the report says, if you can't work out what to do.

    S3rgio
  • whu606, thank you very much for your help!
    I get the following:

    Fatal Error in Gdn_Database.Connection ();

    I leave here a screenshot, to see if anyone can help me out,
    thank you very much again.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @S3rgio

    It's really important you strip out DB user and password details before you post up errors!

    To me, it looks like either you are pointing at the wrong DB, or using invalid credentials.

    You could try deleting the ini files which you have in the cache folder.

    You need to do that any time you move an installation.

    S3rgio
  • This time there is a problem connecting to the database.
    There is a database user (see screenshot). That db user has a password on localhost, but that password is NOT the same on the server.
    Open conf.config.php and make very sure that the password in there is the password for that database user on the server

    S3rgio
  • Now it works perfectly!
    Thank you very much for your help.
    Greetings from Canary Islands

    UnderDog
Sign In or Register to comment.