Please upgrade here. These earlier versions are no longer being updated and have security issues.

Split/Merge remains

Firstly, I enable the Split/Merge plugin. After that I don't want to use it anymore so disable it. But there are still stick box like this remains. Even I tried to remove the plugin. How can I remove the stick box?

Tagged:

Comments

  • KasperKasper Scholar of the Bits Copenhagen Vanilla Staff
    edited February 2013

    I know for a fact that there's an option to remove the "Admin check boxes" in Vanilla 2.1 but I'm not sure whether or not that option is present in Vanilla 2.0 - try going to "Forum Settings" -> "Advanced" in your dashboard and see if you can find it.

    Kasper Kronborg Isager (kasperisager) | Freelance Developer @Vanilla | Hit me up: Google Mail or Vanilla Mail | Find me on GitHub

    hydn
  • Sadly, can't find it :(

  • It sounds more like it isn't disabled. Or it is a cached page.

    grep is your friend.

  • disabled already. clear cache also but the check boxs still remain

  • @bingyang you could delete the plugin /plugins/ folder completely see if that works

  • bingyangbingyang New
    edited February 2013

    @fr3333333x yes, deleted the plugin folder in cpanel also T^T

  • @bingyan yo know what i think? this might be the default checkbox you're seeing , see if it's the actual "split/merge" plugin, else this might be the default, in vanilla 2.0 you should see that checkboxes appearing when you're logged in as administrator or moderator of the site.

  • I had the same thing happen to me as well. Tried split/merge, didn't find it necessary and once disabled/deleted the checkboxes never went away. Installed a clean test forum and used a copy of my active forums database, and no checkboxes.

    Split/Merge changes something to permanently add the checkboxes, and I haven't figured out yet how to remove them.

  • you guys using Vanilla 2.1 ?

  • @kasper's fix works. Just visit yourforum.com/vanilla/settings/advanced

    uncheck the box "Enable admin checkboxes on discussions and comments."

    422
  • @fr3em1nd no, i'm using vanilla 2.0.18.4 so there is no option to uncheck "Enable admin checkboxes on discussions and comments." @hyndn

  • fr3em1ndfr3em1nd ✭✭
    edited March 2013

    go to:
    applications\Vanilla\Views\discussions
    and copy:

    helper_functions.php

    to: themes\yourthemename\views\discussions\

    open the copied:helper_functions.php
    and go to line 37

    and comment it out just like this:

    //$Sender->CanEditDiscussions = GetValue('PermsDiscussionsEdit', CategoryModel::Categories($Discussion->CategoryID)) && C('Vanilla.AdminCheckboxes.Use');;

    see if this works, i havnt tested it. but it's worth giving a try

    else give me the link for your site so i can see. :)

  • edited March 2013

    @fr3em1nd said:
    go to:
    applications\Vanilla\Views\discussions
    and copy:

    helper_functions.php

    to: themes\yourthemename\views\discussions\

    open the copied:helper_functions.php
    and go to line 37

    and comment it out just like this:

    //$Sender->CanEditDiscussions = GetValue('PermsDiscussionsEdit', CategoryModel::Categories($Discussion->CategoryID)) && C('Vanilla.AdminCheckboxes.Use');;

    see if this works, i havnt tested it. but it's worth giving a try

    else give me the link for your site so i can see. :)

    No, it doesn't work.

    (The same thing here too)

  • All I found -
    conf/config.php

    $Configuration['Vanilla']['AdminCheckboxes']['Use'] = TRUE;

    • Have to be FALSE - and check-boxes are gone for now, have to test yet....
    hgtonightgharald
  • @RedZambala That did the trick, nice and easy.

Sign In or Register to comment.