Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Changing the Terms of Service on my Vanilla forum

adamcudnyadamcudny New
edited February 2013 in Vanilla 2.0 - 2.8

Hello, I have a problem.

I must change terms of service on my Vanilla forum. Version which I use is 2.0.18.4. I am using this theme: http://vanillaforums.org/addon/vanillapress2010-theme

I found in internet many instructions, but none of them wanted to work... modifying the config.php, locales etc.

Is there any solution?

Regards,
Adam

Comments

  • aeryaery Gtricks Forum in 2.2 :) ✭✭✭

    here - vanilla\applications\dashboard\locale\en-CA\definitions.php

    There was an error rendering this rich post.

  • I add there this lines:

    $Definition['TermsOfService'] = 'Terms of Service'; $Definition['TermsOfServiceText'] = ' <p>Zgadzasz się na to i na to.</p> ';

    (i'm from Poland and terms of service will be in Polish)

    But still it doesn't work...
    I tried to change ' to " but still the same.

    I must say that I am using Polish locales, this: http://vanillaforums.org/addon/vf_pl_pl-locale

    And this locales is in locales/vf_pl_PL

  • aeryaery Gtricks Forum in 2.2 :) ✭✭✭

    did you clean your cache folder?

    There was an error rendering this rich post.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    you must use

    $Definition['TermsOfServiceText'] = "

    Zgadzasz się na to i na to.

    ";

    not ' '

  • I said that I try use this: " but it doesn't work too...

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    where did you put it in?

    must be in the folder forum/config/locale/definitions.php This does work but you must put it in the right place .

  • I know what is wrong, please tell me how to repair this.

    I said that i use Polish locales (forum is in polish language)
    And, when I change the locales to ENG - IT WORKS!

    So what i must do?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited February 2013

    If you put the $Definitions in the en-Ca local that is why it works because you altered the english locale not the config not the polish locale, please follow carefully

    forum/conf/locale/definitions.php

    At the very worst put the new definitions in every locale you have. One of them should work.

  • adamcudnyadamcudny New
    edited February 2013

    I put polish locales into /locales/vf_pl_PL

    Then, I log in on admin account and change in settings locales from en-CA to pl-PL
    and below i enabled polish locales

    There (/locales/) is also SKELETON locales and when i enabled the skeleton locales - my terms of service works, but i don't have polish language in forum...

    (sorry for my english :) )

    EDIT: I don't have config folder in /forum/.. I have only conf folder but in conf folder i don't have locale folder.. I must create that?

  • adamcudnyadamcudny New
    edited February 2013

    OOOoookay I solve my problem :)

    This:

    $Definition['TermsOfService'] = 'Terms of Service';
    $Definition['TermsOfServiceText'] = "Zgadzasz sie na to i na to.";

    I put into forum/conf/locale.php and it works :)

    Thank you,
    regards

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited February 2013

    These are the files that are supposed to be in the conf directory.

    config-defaults.php, config.php, constants.php, locale.php

    I don't know how you installed Vanilla don't know what the name of the root is, regardless you must have a config.php or the app would not work right.

    please give a link to your site so I can figure out the path to your config.php

  • it is actually conf not config the name of the directory.

    grep is your friend.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @x00 true sorry about that lol I fixed it , thanks for noticing my error :)

Sign In or Register to comment.