Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Ban List Not Working Properly

I've been adding the IP's of SpamBots over the last week to my 'Ban List' under the Moderation panel (currently running version 2.0.18.1). I've noticed a couple issues...

  1. The default view for 'Ban List' shows 20 results. If I click the 'next' link, I'm taken to page 2 which displays 0 results. I've entered roughly 100 IP's over the last week, so in theory I should have 5 pages under 'Ban List' with 20 results per page. Is this a bug within the code?

  2. In addition to full IP's (123.123.123.123), I've also been adding wildcards to the end of my IP's (123.123.123.%) to ban entire ranges as described by @Todd in this discussion: http://vanillaforums.org/discussion/18097/can-i-ban-a-user-by-ip-address

However, it appears that these wildcard bans don't prevent users from signing up. I've had spambots register under an IP within the IP range I have banned.

If anyone can provide some direction to these issues, it would be greatly appreciated. Thank you in advance!

P.S. For what it's worth, my registration method is currently set to 'Approval'.

Comments

    1. The default view for 'Ban List' shows 20 results. If I click the 'next' link, I'm taken to page 2 which displays 0 results. I've entered roughly 100 IP's over the last week, so in theory I should have 5 pages under 'Ban List' with 20 results per page. Is this a bug within the code?

    I am experiencing the same thing. It displays the first 20 on the first page. Then, when I click Next, it shows 0 on page 2. @dmarkw , did you find a solution for this?

  • File a bug on github if you think it is a problem and specify the version of vanilla you are using.

    An alternate solution
    you could use this plugin - it does not however sort by role, but if most of the banned users are in the same block of userid's you could get an idea, also you can expand the number of users per page and use search feature of your browser to highlight of find banned within the web page. with your browser to search for banned.

    http://vanillaforums.org/addon/memberslistenh-plugin

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Any updates on the issue with the "Ban List" only showing first page results?

  • @VanillaDroid said:
    Any updates on the issue with the "Ban List" only showing first page results?

    check github

    if the issue was filed as was previously suggested if should be there.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • johnny_njohnny_n New
    edited November 2013

    [Split Dammit] Exact same issue - not just second page displaying no results, but the ban list doesn't work period - not just with wildcards or IP ranges but single IPs.

  • hbfhbf wiki guy? MVP

    The page bug is real. Click next, and modify the url from page=p2 to page=2 and it will display.

    But it definitely bans users, that functionality is confirmed by the thousands of would be spammers that have been blocked on my site. Wild card is * not %

    UnderDog
  • hbfhbf wiki guy? MVP

    And no, didn't file a bug report on github.

    Am I a horrible person for that? I'll let god decide.

    UnderDog
Sign In or Register to comment.