Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Fatal error: Class 'Gdn' not found in /home/---/public_html/forum/bootstrap.php on line 47

I tried clearing cache folder as per a few other threads here and on StacksOverflow, but clearing cache folder does not seem to help. I'm still having the same issues.



  • delete the cache folder and return cache->Smarty->compile folder

  • What do you mean return?

  • businessdadbusinessdad Stealth contributor MVP

    @aisajib said:
    What do you mean return?

    I guess he means "recreate". An easier way would be deleting all the ini files from the cache folder.

  • @aisajib :) yep "recreate" sorry bad english.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited February 2013

    you need to create a folder called Smarty then another inside it called compile and put it in the cache folder. In case you don't have them there......

  • 422422 Developer MVP

    Is someone who gets paid to make those folders called "procreate"

    There was an error rendering this rich post.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited February 2013

    I think in this case they would be called Miscreate....sssss :(

  • we could make a theme hooks like this though
    $Folder = PATH_CACHE.'/Smarty/compile'; if (!file_exists($Folder)) @mkdir($Folder);

  • you don't have to delete you whole cache file, just delete .ini. files.

    grep is your friend.

  • Guys, I've said in the very first post that I DID TRY deleting the .ini files and even tried the step said in the first answer.

  • even so you shouldn't have to delete the whole cache file. you can clear smarty without clearing the folder themselves. Though I don't see the relevance of smarty.

    I would check you have copied over all the files, and check the file permissions an ownership.

    grep is your friend.

  • The site is back up but error logging in. I'm trying to paste the URL here but it keeps going on to moderation. You could try testing out to visit a post or sign in on forum dot androidkothon dot com.

  • @aisajib, i see it might be javascript problem here, try reuploading all .js files both in themes and in /application/dashboard/ .js files.

  • Hi, should I reupload the js files from the backup I had taken? Or from a fresh archive of the main vanilla forum?

  • i would recommend fresh from main vanilla forums downloaded from the website. But please never forget to make backups before overwriting anything to avoid problems. as said earlier on this thread, remember to clear the cache folder and recreating /Smart/compile/ folder.

    you might need adding this
    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php'; line to your conf/config.php to give you detailed errors you are getting if you encounter one.

    backup backup backup is the best thing to do

  • By the way my forum is at

  • Hi,

    I tried that way. The gdn issue is gone but there's a new problem. Go to and click Sign in. You'll see what I'm talking about.

    What can I do? :(

  • gdn issue is gone after a while but now I'm facing new issue.

    Go to forum(dot)androidkothon(dot)com and click Sign in. You'll see what I'm talking about.

  • RIght now I'm having sign in errors. Try signing in at


  • By the way my forum is at

Sign In or Register to comment.