Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Does Vanilla work with ProxyConnect 1.9.9?

This discussion is related to the Vanilla Proxyconnect addon.

I get the test page successfully authenticating but it never actually logs the user into the forum, no matter what login method I try. @Tim

Can I disable flood control somehow for testing?

Thank you,


  • Looking at the database it never creates the new user either.. but the VanillaProxy cookie is created. Any hints?

  • Figured it out. Bug in ProxyConnect @Tim -- > If two users have the same name it just doesn't log them in, it should throw an error, or you should assign a number.. something. Or this should go into technical documentation.

  • I was wrong :( still doesn't work with different names. Any ideas... Maybe its flood control?

  • I was having the same problem until I added this to config.php:

    $Configuration['Garden']['Cookie']['Domain'] = '';

    Now it works fine.

  • I'm having the same issue -- I confirmed that I have that cookie domain set at you mentioned, zeldatron.

    Anyone figure out how to get this to work? jared?

  • Further information:

    The forums are hosted in a virtual host that is a sub-domain of the primary site:

    The cookies in the VF ACP for the ProxyConnect plugin are set to:

    I also verified that the cookies in the config.php file match:

    $Configuration['Garden']['Cookie']['Domain'] = '';

    The data returned from the Authenticate URL looks correct:

    UniqueID=4 Name=andrew [email protected]

    I'm a little confused as to why the Test ProxyConnect button in the ACP returns:

    "It doesn't seem like we were able to retrieve a logged-in session from the AuthenticateURL you specified. Please make sure you are logged in to your remote application before performing this test.

  • Thanks, doublepost. I'll close this one.

    There was an error rendering this rich post.

This discussion has been closed.