Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

All discussion is not working

I am new to vanilla forum,
i have installed this on my forum,
but all discussion is not working properly,
if i log in as administrator, it shows all discussion,
but if logged in as other account, it shows only that account discussion,
in short all discussion is working as mine button,
please help me.

Comments

  • Options

    Sound like you haven't set permission correctly. Check the permissions for Member, and other roles.

    grep is your friend.

  • Options

    i have tried to set correct permissions
    i have attached images for member permissions, please help. thanks

  • Options

    could be
    1)routing something differently,
    2) your htaccess wrong
    3) you've changed the way the discussions are found in the discussions controller

    you can see all the discussions with

    http://forums.i-shiksha.com/index.php?p=/
    and
    http://forums.i-shiksha.com

    it is blank
    http://forums.i-shiksha.com/index.php?p=/discussions
    and
    http://forums.i-shiksha.com/discussions

    your permissions are ok, as far I can see, and if you are not logged in guests have the same problem.

    where did you get popular from? a plugin, or your own design. If so, revert back to standard and you will see your permissions work fine most likely.

    is blank
    http://forums.i-shiksha.com/index.php?p=/discussions

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    i am using a plugin for that.

  • Options
    businessdadbusinessdad Stealth contributor MVP
    edited March 2013

    I had a look at the forum and, apart from the discussions not showing, I found two errors. One occurs occasionally, when I try to list the Discussions :

    Fatal error: Out of memory (allocated 4718592) (tried to allocate 7680 bytes) in /home/fkmoxjoc/public_html/forums/applications/vanilla/settings/class.hooks.php on line 165

    This could probably be resolved by increasing the memory available for PHP.

    The other is a "simpler" 500 - Server error that occurs when I click on Activity. Unfortunately, it's a default error page without any details.

    I would suggest trying to disable one plugin at a time, and see if the Discussions appear again. If they do, you will have found the culprit. If not, you can spend more time investigating.

  • Options

    @sumitsipani said:
    i am using a plugin for that.

    Your popular discussion plugin - wherever you got it - is probably the cause - sql is probably not working properly or permissions in plugin is incorrect. Is the plugin from the vanilla add-ons? Otherwise, get rid of the add-on until you can make it work.
    If you provide more detailed responses to questions posed, you may get more help.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.