HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Autogrow removed: not helping. Anyway to reactivate it with no bugs?

This discussion is related to the CLEditor jQuery WYSIWYG addon.

Hi,

I love cleditor, but it makes editing difficult when we want to write longer texts, as the text edit box can't adapt its size to the length of the text. Therefore we end up editing in small text boxes, which doesn't help. I see you wrote that you had to remove the autogrow function. No way it can be used without bugs? Should I give up cleditor?

Thanks!

Tagged:

Comments

  • peregrineperegrine MVP
    edited March 2013

    Should I give up cleditor?

    Yes :) use Buttonbar plugin. or

    Kasper's plugin http://vanillaforums.org/addon/wysihtml5-plugin

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    Kasper
  • KasperKasper Scholar of the Bits Copenhagen Vanilla Staff

    Shameless self promotion: Wysihtml5 is also fully compatible with my other plugin, Word Count

    Kasper Kronborg Isager (kasperisager) | Freelance Developer @Vanilla | Hit me up: Google Mail or Vanilla Mail | Find me on GitHub

    businessdad
  • @kasperisager - I saw someone mention yesterday (might have been jfnoubel, actually) that they couldn't use your plugin due to the Vanilla v2.1 requirement.

    The actual hooks you are using in your plugin seem pretty minimal - any chance you could make it compatible with the earlier version of Vanilla?

  • KasperKasper Scholar of the Bits Copenhagen Vanilla Staff

    @KevinHamilton: Bingo - and the reason why the hooks are so minimal is because I've used hooks (or more precisely "hook": Gdn_Form_BeforeBodyBox_Handler) which was implemented in 2.1. If I had to do the same thing in 2.0, it'd be way more messy. It should be easy peasy adding support for 2.0 though; I simply don't have the time nor will to do it I'm afraid. I'm knee-deep in work as is :-)

    Kasper Kronborg Isager (kasperisager) | Freelance Developer @Vanilla | Hit me up: Google Mail or Vanilla Mail | Find me on GitHub

  • Huh, well maybe that is a project I will try taking on then since I'm looking for ways to improve/deepen my understanding of Vanilla

    Kasper
  • Thank you Kevin. As you can see there's an ongoing discussion here

    Peregrine: I tried wysihtml5 plugin but it requires Vanilla 2.1, which I don't have.

    Thank you kasperisager for your comment :)

  • Hi again Kevin, it seems we keep stuck on reactivating autosize AND keeping the edit buttons alive. We get one or the other. So maybe you have some insights on this conversation : http://vanillaforums.org/discussion/23031/resizing-the-edit-box/p2

    Thanks!

  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff

    has anyone got the auto-grow working? Not seeing the error/reason it was removed. I still think of all the editors this is the best one. Maybe we should look at porting over NiceEdit: (http://nicedit.com/) I If have sometime this week I will look into it :)

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Not seeing the error/reason it was removed.

    It caused conflicts with other plugins and did not work the same on all browsers.

    hgtonightadri
Sign In or Register to comment.