Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

[Solved] Organize your categories link doesn't work?

edited March 2013 in Vanilla 2.0 - 2.8

When I click 'Organize your categories' it just sends me to my URL/URL like this: test.com/test.com
How can I fix this and Organize my categories? Thanks!

«1

Comments

  • Options

    When I click 'Organize your categories'

    Where are you clicking? I see no link in the dashboard for "Organize your categories", I just see a non-clickable heading. It is drag and drop.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    http://gyazo.com/250bbaf49e023f1d820601c4065e495f

    I can click on #3

    Where else can I make/edit categories?

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    In the dashboard left side panel click categories once there you enter the name of the category you want to create. After you make several categories you will see them on that same page at the bottom in a sortable table. You can drag them up or down in any order you want. then click save.

  • Options

    When I click that it does the same thing.. URL/URL like this: test.com/test.com

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    try accessing it direct your.domain.com/dashboard/settings

  • Options

    That just brings me to the dashboard. I copied the link from the Hyperlink (http://mydomain.com/vanilla/settings/managecategories) and when I paste that in the Address bar it just does the same thing... (a.test.com/a.test.com).

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    hmmmm Crystal Ball says: You have to check the configuration, give us more information, a link to the problem. Is this embedded is this stand alone, is it self hosted or the hosted version...

  • Options

    sounds like your .htacess it whacked out.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    When I go to this page: http://gyazo.com/de749b5adf71815788fc107b6390b201
    I click on the Header '3. Organize your Categories' and it goes to this: http://gyazo.com/a8a063729bc742d72cc2bc9e75ab88e0
    I use the self-hosted one, and it's stand alone.
    Could it be due to my subdomain settings? : http://gyazo.com/8f9ca59c3ea97c2c279753056fc761e1

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    Could it be due to my subdomain settings? :

    yes it could you need to look into that have your host fix you up , it's the fastest way to get it fixed in my opinion. look in the htaccess like peregrine says, maybe change in the config.php a few things like rewrite urls true, or check to see what it says under web root . Something is not pointing in the right place. Also your forum is not called vanilla is it?

    http://forums.rozarcraft.com

  • Options

    It is called vanilla, I just made the sub-domain 'forums'.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    so everything works but when you try to use the links in the dashboard they redirect you to that test url.

    just taking a wild guess here , try putting this in the conf.php

    $Configuration['Garden']['WebRoot'] = TRUE;

  • Options

    It's not ALL the links, ONLY that specific one. (Categories)

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    ok then it may be a permissions problem , are you administrator ? you should have in the Roles section checkboxes that allow or disallow things. Make sure the administratr can do everything. As well as manage categories.

  • Options

    Why would that effect the link it sends me to?

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    If you don't have permission it won't let you into the manage category section or other sections you don't have permission to edit. This is not a common problem I have encountered before. So I am thinking about all the potential possibilities. That is one of them. for example In the 2.1 version of Vanilla which is not out for mass use yet, moderators won't be able to manage categories. there will not be a permission option for that for them. If you are using 2.1 and are only a moderator you can't go into manage categories. That is why I asked you to check to make sure if you are the administrator or moderator to look in the roles to see if you have permissions to do everything.

    The idea here is to eliminate possibilities and find the root of the problem.

  • Options

    I'm an Admin, I have full access.

  • Options

    The problem seems to be that http://forums.rozarcraft.com/vanilla/settings/managecategories redirects to http://www.forums.rozarcraft.com/forums.rozarcraft.com. I think it's an issue with the subdomain and it conflicting with the /vanilla.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    ok this is what my htaccess says what does yours say?

    
    # Original
    # If you modify this file then change the above line to: # Modified
    
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /. 
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       # RewriteBase /
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
     
    
    

    this is what my config.php says what does yours?

    $Configuration['Garden']['Domain']                              = '';
    $Configuration['Garden']['WebRoot']                             = FALSE; // You can set this value if you are using htaccess to direct into the application, but the correct webroot isn't being recognized.
    $Configuration['Garden']['StripWebRoot']                        = FALSE;
    $Configuration['Garden']['Debug']                               = FALSE;
    $Configuration['Garden']['RewriteUrls']                         = FALSE;
    
    

    do you have other apps like wordpress in that same subdomain root folder?

  • Options
    edited March 2013

    Disregard this, look below.

Sign In or Register to comment.