Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Confirm e-mail goes to spam!

Hello.
I've noticed that my members aren't confirming their email, so I made a test user to see if the email worked.
I got the email, but it went directly into spam.
This is a huge issue, and I need a way to fix it.
Is there a fix to this?
Thanks!

Comments

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    Have your users check their spam folder and mark it as not span then move to inbox then add the address to their address book . They are the ones who put the filters on their mail. You would need to know their filters like for example : Any mail that does not have my full name goes into the spam folder. So in this case you would have to send the full name of the user in the heading of the letter To : Full name of user.

    But what if they also have a filter that says any address I have not sent mail to goes in the trash ? So you see, it is not easy to control what happens to the mail when it reaches the user. You should be glad they even got it lol !!

  • Options
    edited March 2013

    Well, I sent an email to myself, and I didn't set anything up like that.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    You should go into your mail program's preferences and check the junk rules. Some have default filters like the Full name one. Check the anti virus if you have it scanning email it needs to be alerted it is not spam it also uses filters.

    Try doing what I said about marking it not spam and moving it to the inbox. Then try sending yourself another and see if it goes in the spam.

  • Options

    Is there a way I can change what it says when someone signs up to somewhere say to check spam for the email?

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    In the dashboard there is a messages link on the left panel. There you can pick between 3 types of messages , which basically just changes what they look like, Warning , Message , Box

    You can allow the logged in users to dismiss the message or you can make it permanent . In that message you can ask people to make sure they check the spam folder after registration.

    You can also change what the guest box says, howdy stranger etc. and include the part about checking for spam. You can also change the Definition of the Register/apply for membership title in the registration page, and include the part about check the spam. There are a number of ways to do it.

  • Options

    I added the 'Message', but how can I edit the 'Howdy stranger' thing? Also, how can I change the Definition of the Register/apply for membership title in the registration page? Thanks

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    Ok let me gather more definitions but to start , this is how you can edit most definitions.

    $Definition['Howdy, Stranger!'] = 'Welcome Sinner';
    $Definition['GuestModule.Message'] = 'Please Register to post and Check your spam folder for your confirmation or you are going to hell';
    $Definition['Apply for Membership']='Register';
    

    You put those in the conf/locale.php and see how it goes from there

  • Options
    ShadowdareShadowdare r_j MVP
    edited March 2013

    Open your Vanilla dashboard and go to the outgoing email settings. Do you have "use an SMTP server to send email" checked? If you use SMTP and send your website emails through a gmail account or any other well-known service, your new members usually won't receive emails from your website as spam. If you don't use an SMTP server, then you may need to create an SPF record for your website's domain.

    Add Pages to Vanilla with the Basic Pages app

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
  • Options

    @Shadowdare said:
    Open your Vanilla dashboard and go to the outgoing email settings. Do you have "use an SMTP server to send email" checked? If you use SMTP and send your website emails through a gmail account or any other well-known service, your new members usually won't receive emails from your website as spam. If you don't use an SMTP server, then you may need to create an SPF record for your website's domain.

    I did both of these to no avail.

  • Options
    ShadowdareShadowdare r_j MVP
    edited March 2013

    You should check out these documents from Google:

    If nothing works, then consider disabling email activation. A lot of bots can already activate accounts from the emails. If you are planning on sending out newsletters, then it's the user's problem if the user inputs a fake email address. Don't worry about bots registering on your website if you install a plugin that adds extra questions to the registration page to go along with a CAPTCHA form. Bots usually won't get past this point.

    Add Pages to Vanilla with the Basic Pages app

  • Options

    I fixed the issue. I just needed to get my email sent from a non-shared IP, which is what my webhost had. I set up my email through Mailjet, and now it's not marked as spam. Thanks for your help!

  • Options

    Setting up an external SMTP server works most of the time. Glad you got it working!

    Add Pages to Vanilla with the Basic Pages app

  • Options
    lifeisfoolifeisfoo Zombie plugins finder ✭✭✭

    @TrulyRazor said:
    Hello.
    I've noticed that my members aren't confirming their email, so I made a test user to see if the email worked.
    I got the email, but it went directly into spam.
    This is a huge issue, and I need a way to fix it.
    Is there a fix to this?
    Thanks!

    https://github.com/vanillaforums/Garden/issues/1572

    There was an error rendering this rich post.

Sign In or Register to comment.