Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

wordpress mangling embed URL

ellisgeekellisgeek Sheboygan County, Wisconsin New

I am attempting to embed my vanilla forum into my wordpress+buddypress based site. But when I put the embed code into a page, wordpress changes the url from

< script type="text/javascript" src="http://localhost:8080/vanilla/plugins/embedvanilla/remote.js">< /script>


and of course the page fails to load.
Does anyone know how to go about fixing this?


  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    In your conf/config.php what do you have for these?

    $Configuration['Plugins']['EmbedVanilla']['RemoteUrl'] = '';
    $Configuration['Plugins']['EmbedVanilla']['ForceRemoteUrl'] = FALSE;
    $Configuration['Plugins']['EmbedVanilla']['EmbedDashboard'] = FALSE;
    $Configuration['Garden']['RewriteUrls'] = TRUE;
  • ellisgeekellisgeek Sheboygan County, Wisconsin New

    Nothing didn't know i needed to set those :S
    And i can guess the first one but what are the other 3?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Try setting them to TRUE or FALSE and see what works. If you set the remote url in the dashboard it should appear in the config.php , That is why I ask what do you have for these. That is where you can look to see if the url is correct and or to change the values to make it work

  • ellisgeekellisgeek Sheboygan County, Wisconsin New

    Ok so I added the lines that you posted and edited the first one to reflect the correct url to the discussions page but still no go :( will mess with the others now!

  • ellisgeekellisgeek Sheboygan County, Wisconsin New

    So i have messed with the settings but no cigar. I forgot to mention that i have the wordpress Vanilla Forums plugin and the only thing broken is integration, comment integration is fine!

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Some people have fixed it by disabling the plugin in wordpress but you would have to test. There are many discussions covering this just search a little.

Sign In or Register to comment.