Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

IndexPhotos not working with

This discussion was created from comments split from: IndexPhotos is missing the following requirement*.

There was an error rendering this rich post.


  • My community loves this plugin and it's the main reason I hadn't upgraded to the latest version until today when I did, for other reasons. I suspected people would complain, and they did.

    I was running version 2.0.17 and got the plugin to work simply by changing the required application to 2.0.17 in the class.indexphotos.plugin.php file. Today I tried to amend the same line to (and 2.0.18, and taking out that line...) but no luck. Not sure if there's an easy fix to that (I have absolutely no knowledge of php) but it seemed worth asking...

  • UnderDogUnderDog MVP
    edited March 2013

    Ok, so now you have an upgraded version of Vanilla and the plugin is not working, can you explain what isn't working? Uploading, clicking, any steps to reproduce what isn't working might help in getting a solution.

    Browser? Version? Windows? Macintosh? IE? Why?
    Anything helps. Screenshots?

    There was an error rendering this rich post.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    Try this method it's old but looks ok to me, I did this on a forum I set up but I think I hacked the core, I have been searching for the mod I made if I find it I will post it.

  • 422422 Developer MVP

    works on our demo forums and they run


    There was an error rendering this rich post.

  • Thanks so much for having a look at this!

    @vrijvlinder ~ Thanks for the link ~ I tried those instructions but unfortunately didn't notice anything different about the site after...

    @UnderDog ~ I am attaching a screen grab of the dashboard/plugins screen: after upgrading a number of plugins didn't re-enable (most didn't matter, but a couple I would have liked to keep). They weren't labeled either so it wasn't clear which was which but I tried them all and each time it triggered the same error message: "The addon could not be enabled because it generated a fatal error: The plugin folder was not properly defined." I am using Firefox on Mac (also tried Safari after you asked, with the same result.)

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    The plugin folder is what houses the plugin. Check that the folder name matches ->this defines the plugin, look for errors in your editing.

    $PluginInfo['IndexPhotos'] = array(
       'Name' => 'IndexPhotos',
       'Description' => "Adds user photos to discussions list.",
       'Version' => '1.1',
       'RequiredApplications' => array('Vanilla' => ''),
       'RegisterPermissions' => FALSE,
       'Author' => "authorname",
       'AuthorEmail' => '[email protected]',
       'AuthorUrl' => ''
  • Thanks @vrijvlinder. I checked and the folder name does match.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Ok and the plugins folder is where it should be ? It is very strange that there is no info of the plugins installed in your screenshot. I would check the installation carefully and make sure everything is where it should be.

  • There is no info on the plugins that ceased to be compatible with and which were all collated at the top though the ones that still work are showing up properly (below what's captured in the screen shot).

    The plugins folder is still where it was before the upgrade and I have never moved it. The path on my webdisk is [Web Address]>public_html>TheDreamBoards>plugins. "TheDreamBoards" is what I named the forum folder on installation.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited March 2013

    I would remove the incompatible plugins from the installation, it's dead wood. Can't think of anything else, it works on my installation no problem. I would disable plugins and enable one by one maybe there is a conflict somewhere. Or remove and reinstall them one by one. Delete old cache files and ini files.

  • Thanks for the suggestion, will try that an report back later.

  • That didn't work for the index photos though your suggestion does seem to have fixed the issue with notifications I reported elsewhere so thanks :-).

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    How did you install the plugin? did you download then ftp ? Just curious because sometimes direct upload to the directory from the panel can corrupt some files or exclude files.

  • I downloaded it, then did a drag & drop of the folder into the TheDreamBoards>plugins folder via the web disk on my hard drive - that's always worked before for any of the plugins. Not sure how to do it directly from the cPanel or any other way as I've never tried but I can look into it later...

  • you might not have correct read permissions on each of the plugin folders that don't work. or the case sensitivity is wrong - 
    and you should look in your config.php and remove the enabled lines e.g.
    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';  // leave this one.
    // remove these line
    $Configuration['EnabledPlugins']['VersionCheck'] = TRUE;
    $Configuration['EnabledPlugins']['PeregrineBadges'] = TRUE;
    e.g.   in each plugin an array exists in defualt.php or class.Yourplugin.php
    $PluginInfo['AddMenuitem'] = array(
    the directory in this should be

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Thanks, Peregrine. I checked the config.php file and the plugins that don't work don't show permissions, period (i.e. there's no line referring to them). Case sensitivity doesn't seem to be the issue either... I double checked and it was written correctly with upper case where required i.e. IndexPhotos.

Sign In or Register to comment.