HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

[GitHub #1562] Upgrade through /utility/update still Unknown column 'AllIPAddresses'*

edited April 2013 in Vanilla 2.0 - 2.8

So I was upgrading my site (books.cat) to a dev version of vanilla to test some things (yeah, I shouldn't be playing with bleeding edge versions on a live site... but it's so tempting to have new shiny things). Anyway, I cleared my .ini files and I navigated to books.cat/utility/update and it was like "no you evil, go away" (seriously it just gave the error message it gives me in the rest of the site:

<

pre>

Fatal Error in Gdn_Database.Query();

Unknown column 'AllIPAddresses' in 'field list'
update GDN_User User
set DateLastActive = :DateLastActive,
LastIPAddress = :LastIPAddress,
AllIPAddresses = :AllIPAddresses
where UserID = :UserID
The error occurred on or near: /hermes/waloraweb001/b401/moo.teamcoltra/books/library/database/class.database.php
290:
291: if (!is_object($PDOStatement)) {
292: trigger_error(ErrorMessage('PDO Statement failed to prepare', $this->ClassName, 'Query', $this->GetPDOErrorMessage($this->Connection()->errorInfo())), E_USER_ERROR);
293: } else if ($PDOStatement->execute($InputParameters) === FALSE) {
294: trigger_error(ErrorMessage($this->GetPDOErrorMessage($PDOStatement->errorInfo()), $this->ClassName, 'Query', $Sql), E_USER_ERROR);
295: }
296: } else {
297: $PDOStatement = $this->Connection()->query($Sql);
298: }
Backtrace:
/hermes/waloraweb001/b401/moo.teamcoltra/books/library/database/class.database.phpPHP::Gdn_ErrorHandler();
[/hermes/waloraweb001/b401/moo.teamcoltra/books/library/database/class.database.php:294] PHP::trigger_error();
[/hermes/waloraweb001/b401/moo.teamcoltra/books/library/database/class.sqldriver.php:1650] Gdn_Database->Query();
[/hermes/waloraweb001/b401/moo.teamcoltra/books/library/database/class.sqldriver.php:1615] Gdn_SQLDriver->Query();
[/hermes/waloraweb001/b401/moo.teamcoltra/books/applications/dashboard/models/class.usermodel.php:3328] Gdn_SQLDriver->Put();
[/hermes/waloraweb001/b401/moo.teamcoltra/books/applications/dashboard/models/class.usermodel.php:2220] UserModel->SetField();
[/hermes/waloraweb001/b401/moo.teamcoltra/books/library/core/class.session.php:343] UserModel->UpdateVisit();
[/hermes/waloraweb001/b401/moo.teamcoltra/books/library/core/class.auth.php:41] Gdn_Session->Start();
[/hermes/waloraweb001/b401/moo.teamcoltra/books/bootstrap.php:206] Gdn_Auth->StartAuthenticator();
[/hermes/waloraweb001/b401/moo.teamcoltra/books/index.php:34] PHP::require_once();
Variables in local scope:
[Sql] 'update GDN_User User
set DateLastActive = :DateLastActive,
LastIPAddress = :LastIPAddress,
AllIPAddresses = :AllIPAddresses
where UserID = :UserID'
[InputParameters] array (
':DateLastActive' => '2013-03-30 20:02:21',
':LastIPAddress' => '108.183.75.64',
':AllIPAddresses' => '72.43.158.238',
':UserID' => 1,
)
[Options] array (
'ReturnType' => NULL,
)
[ReturnType] NULL
[PDOStatement] array (
'queryString' => 'update GDN_User User
set DateLastActive = :DateLastActive,
LastIPAddress = :LastIPAddress,
AllIPAddresses = :AllIPAddresses
where UserID = :UserID',
)
Need Help?
If you are a user of this website, you can report this message to a website administrator.
If you are an administrator of this website, you can get help at the Vanilla Community Forums.
Additional information for support personnel:
Application: Vanilla
Application Version: 2.2a1
PHP Version: 5.2.17
Operating System: Linux
Server Software: Apache/2
Referer: http://www.books.cat/
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.43 Safari/537.31
Request Uri: /dashboard/settings
Controller: Gdn_Database
Method: Query

Can you help me? What do I need to do to upgrade successfully?

Tagged:

Best Answer

Answers

Sign In or Register to comment.