HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Vanilla 2.1 blank page issue

Hi, I am trying to install Vanilla 2.1 as I want to port my forum to Vanilla, but am waiting for 2.1 to become available as it's such an important update. Previously tested the previous versions of Vanilla on my server which work well.

However, 2.1 on my server gives a weird error. Whenever I post something, it is properly registered and shows up in the topics overview, but when clicking to the actual page I get a totally white / blank page.

I have tried to enable error reporting but no luck. Also, I have tried installing in my website main directory and into a sub directory, also changing the path in .htaccess as in RewriteBase /garden

Any ideas? Am running latest php and Apache with the required PDO etc.

UnderDog

Comments

  • Check your Apache error logs, there might be something in there. After that, turn on your debugging modus in Vanilla 2.1, but first : the apache error logs.

  • KswiftKswift
    edited March 2013

    Thanks! I have looked at the error logs and I see this:

    File does not exist: /home/xxx/public_html/entry

    File does not exist: /home/xxx/public_html/404.shtml

    (xxx is my website dir)

    What is weird is that I have installed Vanilla into public_html/garden so it should not even be looking in the root web directory.

    My htaccess file has this line uncommented:
    RewriteBase /garden

    UnderDog
  • Wow... my next step was to enable bug checking:

    I added this this to conf/config.php

    $Configuration['Garden']['Errors']['LogEnabled'] = TRUE;
    $Configuration['Garden']['Errors']['LogFile'] = 'logs/error-log';
    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    Then I got to see an error:

    Fatal error: Call to undefined function mb_detect_encoding() in /home/africais/public_html/garden/library/vendors/simplehtmldom/simple_html_dom.php on line 988

    So, next I commented two lines in simple_html_dom.php:

    // $charset = mb_detect_encoding($this->root->plaintext . "ascii", $encoding_list = array( "UTF-8", "CP1252" ) );

    // if (is_object($debugObject)) {$debugObject->debugLog(2, 'mb_detect found: ' . $charset);}

    After I did that, my topics started showing up again. But the real problem here may be that my php does not have mbstring installed?

    UnderDoghgtonight
  • I had to recompile my Php wih mb_detect enabled. Now it's working!

    UnderDogperegrinehgtonight
  • Awesome! If you can document your steps on the Vanilla Wiki that would be great.
    I've created a wiki page for you. All you need is to register and basically copy / paste the results of this thread.

    http://vanillawiki.homebrewforums.net/index.php/Debugging

    peregrineShadowdare
  • Cool! Will do, and thanks a lot for your support.

    UnderDog
  • The Wiki itself seems to also have a bug... can't remember mistyping my mail:

    **Vanilla Community Wiki could not send your confirmation mail. Please check your e-mail address for invalid characters.

    Mailer returned: Unknown error in PHP's mail() function. **

  • I tried to change my email to another one, but still get this error on the Wiki, in the meantime it won't allow me to post there.

  • See PM and I'll alert @hbf to take a look at emailing problems

Sign In or Register to comment.