Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

The server encountered an unexpected condition which prevented it from fulfilling the request.

vrijvlindervrijvlinder Papillon-Sauvage MVP
edited April 2013 in Vanilla 2.0 - 2.8

I am trying to set up 2.1b1 on a new forum. So far it seemed to all go well except the plugins and themes generate this error I am sure other may too. Have checked everything as per the discussions here to see what gives but can't figure it out.

I purged the ini and cache, RewriteURL FALSE after TRUE failed, Tables in database seem fine. But That I am not sure what not fine looks like. No errors from the database. while I wait for my Host to figure out if it's me or them, I want to speed up the process if I can. They wanted me to wait 48 hours once for tech support , then I figured out the problem in 8 so I am betting the same here but in 4 hours since I know a bit more now.

Since there are no error messages except this and it points to server troubles not necessarily Vanilla install . Maybe someone has a clue?

The server encountered an unexpected condition which prevented it from fulfilling the request.
The script had an error or it did not produce any output. If there was an error,
you should be able to see it in the error log.

and to load resource: the server responded with a status of 500 (Internal Server Error)

according to their knowledge base:

Why is my script returning a Server 500 error?

Explore the following possibilities to troubleshoot: 

Does your account include CGI accessibility? yes
Did you call your script with the correct url? yes
Did you upload it to the correct directory? yes
Does your script expect values? If so, did you use the right method (POST/GET)? yes
If you edited path variables in the script, are they correct? yes
Are you sure you uploaded the script in ASCII mode? If not, you will have to upload them in ASCII mode to make them work. yes

I thank you in advance for your help when you find the time:)



  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited April 2013

    I followed this lead and tried to enable plugins and themes via the config.php and it worked. I enabled cleditor . all viewed , debugger, emotify,gravatar And my Themes from the config.php.

    So the issue is that something is not allowing the config.php to be populated with the dashboard settings.

    If you have this issue, you may be able to enable the plugins manually from your config.php . I recommend you enable debugger for sure. And uncomment the pertaining lines or copy it into the config.php .

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php'; // Used at installation time and you should use it too view when debugging

    here is a list of $Configurations from my own config.php

    $Configuration['Garden']['Theme'] = 'default';
    // Plugins
    $Configuration['Plugins']['GettingStarted']['Dashboard'] = '1';
    $Configuration['Plugins']['GettingStarted']['Plugins'] = '1';
    $Configuration['Plugins']['GettingStarted']['Profile'] = '1';
    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';
    $Configuration['EnabledPlugins']['embedvanilla'] = TRUE;
    $Configuration['EnabledPlugins']['Gravatar'] = TRUE;
    $Configuration['EnabledPlugins']['Emotify'] = TRUE;
    $Configuration['EnabledPlugins']['FileUpload'] = TRUE;
    $Configuration['EnabledPlugins']['cleditor'] = TRUE;
    $Configuration['EnabledPlugins']['AllViewed'] = TRUE;
    $Configuration['EnabledPlugins']['Debugger'] = TRUE;

    I love back doors :)

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    So to make this story short, apparently if you jolt it by manually enabling the stuff in the config.php somehow it all starts to work. So far . And this is a pretty decent method to start the propellers and Release the 2.1b1 Crikee!!!!!!!!!!!!!!

Sign In or Register to comment.