Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Vanilla Cookies Blocked by IE

edited February 2007 in Vanilla 1.0 Help
Hi there, I have a new Vanilla Forum up and running, but IE is blocking the cookies by default. This is causing login problems and is confusing forum users. No explicit message or pop-up is displayed regarding this cookie block, but if you double click on the privacy icon (eye) you get the blocked cookie message. The website is http://www.CraftBrewingForum.com This URL runs as a mask on top of http://www.bensullins.com We suspect that the URL masking is causing the cookie-block issue. Privacy Report Summary from Internet Explorer. "Could not find a privacy policy for http://www.bensullins.com/craftbrewingforum.com/signin.php. To view this site's privacy policy, contact the Web site directly." Any comments, suggestions or feedback is greatly appreciated! Thank you, Wesociety

Comments

  • Options
    MarkMark Vanilla Staff
    What version of vanilla are you using?
    What are your cookie settings (look on the settings / globals form)?
    Where is Vanilla set up on your server (ie. web accessable directory)?
  • Options
    ithcyithcy New
    edited June 2006
    //edit: what mark said
  • Options
    Hello and thank you for your help! I am running version 0.9.2.6 Web-path to Vanilla is www.bensullins.com/craftbrewingforum Cookie domain is www.bensullins.com If I change the cookie domain to craftbrewingforum.com would this break the login ?
  • Options
    I'd suggest trying either .bensullins.com or .craftbrewingforum.com (with the prevailing . ) and see which gives best results.
  • Options
    MarkMark Vanilla Staff
    edited June 2006
    I don't think it would break the login, no. People would have to re-authenticate when they return to the forum, though.

    I'd give that a shot. You can also try the domain minus the www at the beginning: .craftbrewingforum.com (note the dot at the beginning). That will ensure that people typing http://craftbrewingforum.com into their web browser get authenticated properly as well.
  • Options
    edited June 2006
    Hi minisweeper & Mark, Thanks for the suggestion, but that did not fix the problem. Any other suggestions?
  • Options
    Did you clear out all your existing cookies before re-testing it?
  • Options
    edited June 2006
    Yes, existing IE cookies were deleted and the issue persists.
    Here's a screenshot with the blocked notice and Cookie settings in a window behind that.

    Image Hosted by ImageShack.us
  • Options
    What exactly does it mean by 'privacy policy' ? It might not be an issue with the cookies as such, just that it wont accept them for another reason?

    also, should i keep the capital M in my name? i cant decide
  • Options
    in IE, if you go to Tools->Internet Options->Privacy tab, what does it say?
  • Options
    edited June 2006
    The default Internet Explorer options are used. I have duplicated the issue on multiple computers that use default IE 6 settings. Privacy level is set to Medium. Mark, do you have any other suggestions? :)
  • Options
    Update: We decided to cutover the site to one of our other webhosts. Now we don't have the URL masking and the cookie issue in IE has dissappeared. Thanks to all for your comments and suggestions.
  • Options
    Werd up. I wonder how to solve it with the maskin in place?
  • Options
    Possible way to solve with masking in place: Since it can't find a privacy policy, you can probably set up a compact privacy policy (see P3P page at W3C) to make the warning go away.
  • Options
    OH NO! Microsoft is blocking Vanilla's cookies, because they want to be in the forum scene as well!! :D You'll see! Next month they'll come up with their own ForumLive software which integrates with IE... bah :P
  • Options
    edited June 2006
    I had the same problem. However, I found out that this was not caused by a missing p3p file, but by redirecting: my domain jerommeke.com was redirecting to my other domain wientjes.org/jerommeke to save hosting costs - but in a frame, so jerommeke.com was preserved in the location bar of the browser. IE did not like this. So I changed to a normal redirect and the issue was solved.

    edit: should have read better ;-)
  • Options
    I had a similar problem today - turned out to be nothing to do with Vanilla. I was using an underscore in my domain name - this character is not valid for domain names. I was just testing this locally, and the domain name i chose was "test_vanilla.com". Firefox didn't have a problem with it - but IE would silently reject cookies - so the symptom was you sign in ... and .. you're not signed in! very frustrating. Changed the domain name to "test-vanilla.com" (hyphens are allowed) .. and it works! :D (this is a duplicate posting - also http://lussumo.com/community/discussion/3865/)
This discussion has been closed.