Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Poll not working

This discussion is related to the kPoll addon.


I have added Kpool to my plugin and created a poll but its not recording any data or even registering votes.

Can anyone help?

Many thanks


  • lifeisfoolifeisfoo Zombie plugins finder ✭✭✭

    What version of vanilla are you using? 2.0.x or 2.1?

    There was an error rendering this rich post.

  • im using

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited April 2013


    ok it works for me after some fixes can you try using this version?

    Also, it only appears in the discussions index page. In case you were looking elsewhere...

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited April 2013

    After submitting the vote on the poll you need to use the discussions link to see the panel again, which goes away after you vote. Maybe a notice there saying vote submitted would help people know...

  • thanks @vrijvlinder ....i will try it out now

  • @vrijvlinder Still doesnt work :(

    The poll displays correctly on the discussions section - but when i vote still no data is being logged.
    Also when i create the poll - under the section where it says Current/Archived poll Results there is no data there either :(

    Not sure what im doing wrong?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Not sure either, it is a very simple poll. There is not much to it. Have you tried making several?
    It worked on my installation . I will look into it more.

  • Yeah I have tried making a few but for some reason it wants to be awkward ;)

    Well thanks a lot for trying anyways :)

  • Ok well randomly the poll worked...ONCE ;) and now it has stopped working again! Does kpoll add any extra files anywhere that I should maybe delete and re-install? or is it fine to just remove the plugin and reinstall to get it working?

  • it's not working with me either; hoping the author can update it or sink this to avoid further installations until fixed!

  • peregrineperegrine MVP
    edited July 2013

    it worked for me, what version of vanilla are you using.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    This plugin works as intended. You can't ask for a plugin to be removed or sink it when it works for 99% of the people.

    I tested this on several installs even 2.1 and it works fine. Maybe you have another plugin which may be affecting it and causing problems. Check for compatibility issues.

Sign In or Register to comment.