Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

FileUpload Hangs on Uploads

I installed the plugin FileUpload on an install of 2.1b1.17. Users have permission to upload/download files, but when attempting to actually upload a file, the progress bar just stalls, and never completes.

I checked my permissions, and both uploads and uploads/FileUpload have recursive 755 permissions. When a user tries to upload something, it does actually create a folder with the image on the forum server, but for some reason, never stops hanging for the user. If they just go ahead and press submit while the FileUpload bar is still going, it does not "attach" the file at all. (That is, the file is actually created on the server, but never linked to the post.)

I tried to fix it using this post, but that doesn't appear to be my issue, since it occurs across multiple themes, and even with the php insert fix for a given theme.

Any other ideas?



  • dylanb02dylanb02 New
    edited May 2013

    Having the exact same issue! Glad I'm not the only one.

    Using 2.1b and don't have APC setup but don't need status bars.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited May 2013

    The problem is related to some errors in fileupload.js and in the jquery 1.7.1

    I have a bogus fileupload on my 2.1 install and have tried everything , I even got a jquery file from the source and put it in my js library and pointed upload to that file. It still will not work.

    It does upload, if you look in your uploads folder the pics are there, however the thumbnails may not be there. And it hangs in the progress mode.

    There is no solution yet that I have found, I commented the errors in the fileupload.js

    they relate to the APC progress bars .But that did not fix the jquery 1.7.1 unrecognized token '>' which I can't trace the root of it.

    Sorry you better stick to for now

  • Is there any way to disable the progress bar entirely to fix the issue? Just let the page hang until suddenly the upload completes?

    I'm sorry, I know it's lazy of me, but I'm trying to avoid having to entirely re-implement the forum in order to rollback to the old version.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited May 2013

    Any fix involves something drastic, like replacing the core files with new. That might work, but it may not. I do not know. People don't seem to know how to fix this . it does not happen to all with 2.1 but it does to some including me.
    Going back to 2.0 is not easy either from what I have heard.

    What I read was that you could do a second install and import the data back in.

    The progress bars are just an image, an animated gif. It has no impact on this problem.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
  • Do you have any suggestions as to what to try to fix it in 2.1b?

  • Upgrading to the GitHub version of this plugin (1.7.1) fixed this issue.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited June 2013

    Good catch ! there is a file missing in the previous versions.

    get it here, I recommend removing the version requirements .

    @Lark there you go !!

  • GAH. I'm so sad that this got fixed now that I've reverted to the stable version. Ah well. Next time. Thanks for the fix @dylanb02!

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited June 2013

    Don't feel bad you are better off with 2.0 I am not upgrading until it is stable for now it is only for test environments

  • LarkLark
    edited June 2013

    I want to upgrade, if only because the password reset in 2.1 allows users to reset their own passwords, as opposed to having to send plaintext to them if admin wants to reset.

    But at the same time, the stability of the rest of 2.0 is appealing.

Sign In or Register to comment.