HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Admin only?

This discussion is related to the CLEditor jQuery WYSIWYG addon.

When I'm logged in as admin the editor shows up, but when I'm logged in as non-admin it doesn't and I can't find anything in the roles and permissions to allow it to non admin accounts... a little help?

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    look to see in the roles and permissions of the member accounts if they have allowed to post checked

  • I don't see anything like that in roles and permissions... I've created custom roles, might that have something to do with it? Please see attached capture of all my roles and permissions settings available.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    What are the custom roles? I don't think they would interfere with each other. I have the same settings for members and can post. Maybe disable some plugins. I do know that some jquery conflicts may cause cleditor to react buggy.So disable plugins and see if the form appears again, this includes cleditor, disable them all then one by one until you trace the root of the problem.

  • Custom Roles are like... New Employee, Novice Employee, etc. I just tried disabling everything but the editor and still no luck... weird that it works for admin :|

  • This is interesting... when replying viewing discussions the editor is available to these roles, but just not when they are starting a new discussion.

  • sound like a javascript conflict, try disabling pluigns, also could be a a cache issue.

    grep is your friend.

    UnderDog
  • Post Scheduler was the conflict on this issue as well. As soon as I disabled the plugin, this one started working properly!

Sign In or Register to comment.