Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

New Discussions Viewable only by Admin & Author, HELP!

I'm about to launch my company forum and in the last few tests I realized that when a new discussion is started, only administrators and the author can see them in the list of discussions. Anyone know what permission is needed to be added to my custom roles so that they can view discussions?


  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    You need to give those roles the same permissions members have , members should be able to post. Star new discussions and view .

  • Options

    They have them.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    are you sure this is being saved to config,php ?

    Look in the config.php for the role settings. They should look something like this but having to do with the new roles created.Check to see what role number they are assigned.

    $Configuration['Garden']['Registration']['DefaultRoles']        = array('8'); // The default role(s) to assign new users (4 is "Member")
    $Configuration['Garden']['Registration']['ApplicantRoleID']     = 4; // The "Applicant" RoleID.
    $Configuration['Garden']['Registration']['InviteExpiration']    = '-1 week'; // The time before now that an invitation expires. ie. If an invitation was sent within the last week, it is still valid. This value will be plugged directly into strtotime()
    $Configuration['Garden']['Registration']['InviteRoles']         = FALSE;
    $Configuration['Garden']['Registration']['ConfirmEmail']        = FALSE;
    $Configuration['Garden']['Registration']['ConfirmEmailRole']    = 3;
  • Options

    This is what is in the garden section of my config file...

    // Garden
    $Configuration['Garden']['Title'] = 'Community';
    $Configuration['Garden']['Cookie']['Salt'] = 'JHVWEULIGK';
    $Configuration['Garden']['Cookie']['Domain'] = '';
    $Configuration['Garden']['Registration']['ConfirmEmail'] = FALSE;
    $Configuration['Garden']['Registration']['Method'] = 'Approval';
    $Configuration['Garden']['Registration']['CaptchaPrivateKey'] = '';
    $Configuration['Garden']['Registration']['CaptchaPublicKey'] = '';
    $Configuration['Garden']['Registration']['InviteExpiration'] = '-1+week';
    $Configuration['Garden']['Registration']['InviteRoles'] = FALSE;
    $Configuration['Garden']['Email']['SupportName'] = 'Community';
    $Configuration['Garden']['Version'] = '';
    $Configuration['Garden']['RewriteUrls'] = TRUE;
    $Configuration['Garden']['CanProcessImages'] = TRUE;
    $Configuration['Garden']['Installed'] = TRUE;
    $Configuration['Garden']['InstallationID'] = 'B1E35DBA3-DB50C';
    $Configuration['Garden']['InstallationSecret'] = '620ce09735d410304afdef944deea9cfbcd';
    $Configuration['Garden']['Format']['Hashtags'] = FALSE;
    $Configuration['Garden']['PrivateCommunity'] = TRUE;
    $Configuration['Garden']['Html']['SafeStyles'] = FALSE;
    $Configuration['Garden']['Theme'] = 'fb-vanilla';
    $Configuration['Garden']['Messages']['Cache'] = 'a:0:{}';

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited June 2013

    remove the personal info please like the install id etc

    Do you know what permissions are on the config.php ?

    The roles you created should be reflected but do not appear . Makes me think the changes you made are not being written to the config.php

    try setting the config.php to permissions on the file 755 maximum 775

  • Options

    I edited half of the install ID out before posting, same goes for install secret.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    after you check the permissions if you change them, re try setting the roles again .

  • Options

    This is amazing, I've narrowed it down to permissions pertaining to the post scheduler plugin...

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
  • Options

    Yep, that was it... As soon as I disabled it, posts started showing up!

  • Options

    Thanks for the help!

Sign In or Register to comment.