Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Problem with Clipboard 2.0 on Vanilla 1 prerelease

edited June 2006 in Vanilla 1.0 Help
Hiya,

I have a problem with Clipboard 2.0.

I have this message when I try to start a discussion:

A fatal, non-recoverable error has occurred
Technical information (for support personel):

Error Message
An error occurred while attempting to retrieve Clipping items.
Affected Elements
ClippingManager.GetClippingsByUserID();

The error occurred on or near: Table 'vanilla.LUM_Clipping' doesn't exist


The table LUM_Clipping. How can I add this table?

(I installed vanilla 1 pre release from the svn repository (revision 445 I think, updated to 451 today), on a linux server (centos4) with apache 2.0.52, php 5.0.4 and mysql 4.1.18).

Comments

  • Options
    i have the same problem, just forgot to post it. I dont know what revision it was but was fairly recent.
  • Options
    Adding it is easy enough but the issue is that it wasnt added automatically. It could be a php5 or an apache2 bug but i dont see why. Have you tried installing and uninstalling the extension?
  • Options
    yes, i dont think my hosting is php5 anyway but it still didnt work.
  • Options
    edited June 2006
    Yep, I tried it.

    Unstalled, the forum work corectly, but same bug when I reinstall it.
  • Options
    Hmm, mark, do users have to create the table themselves? Could do with a readme of some kind in that case.
  • Options
    Try running this query on your database: CREATE TABLE `LUM_Clipping` ( `ClippingID` int(11) NOT NULL auto_increment, `UserID` int(11) NOT NULL default '0', `Label` varchar(30) NOT NULL default '', `Contents` text NOT NULL, PRIMARY KEY (`ClippingID`) ) TYPE=MyISAM;
  • Options
    Yep, it works. Thank you.

    Now I have to figure out how works this extension.
  • Options
    You just add stuff to it in your account panel and then you can click to insert it when you're posting.
  • Options
    edited June 2006
    I can create clipboards but when I add a comment, the clipboard that i select is not paste in to the comment.
This discussion has been closed.