Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

IIS Vanilla 1.0 Install Problem

edited July 2006 in Vanilla 1.0 Help
I am attempting to evaluate Vanilla. Yesterday I installed Version 0.9.2.6 without incident. Everything worked fine. When I saw that some of the new extensions require Version 1.0, I decided to install that. Since I am still in the evaluation stage I decided to simply do a full install of 1.0, rather than an upgrade. I created a new folder. Uploaded the software. And tried to run installer.php. I get the first page, but when I press enter to proceed to the second page the system hangs and I get a blank HTML page back. When I view the source of the HTML page I find this - The following error occurred: [code=CANT_CONNECT] Could not connect because of networking problems. Contact your system administrator. Strange that 0.9.2.6 installs cleanly on my server. 1.0 does not. I never get to the point in the installer where I can enter my server and database information. Nothing. I am hosted thru Host Excellence. My information is as follows. PHP 4.4.1 Windows NT IIS7 5.0 build 2195 Any ideas? Thanks

Comments

  • Options
    What mysql ver are you running?
  • Options
    MySQL Client API 3.23.39
  • Options
    re. MySQL ver - as of yet, it doesn't even get to the point of asking me for my server name.
  • Options
    My bad. MySQL - 4.0.16
  • Options
    Hmm. It's happened before that people get a blank page after setting up mysql details, but not after step 1...It cant even be a php5 issue this time. I wonder if it's an IIS or permissions thing *scratches head
  • Options
    MarkMark Vanilla Staff
    Well, step 1 checks file permissions, so it must be something to do with that.

    Vanilla 0.9.2.6 and Vanilla 1 are very VERY different applications. The first step in Vanilla 0.9.2.6 just checked permissions, but the first step in Vanilla 1 actually creates configuration files on your server. It is likely something to do with that.

    The installer has a lot of debugging stuff thrown in there so that you get verbose error messages, but whoever configured your server has the power to override inline php configuration settings and make it so that errors don't get treated properly and instead you get strange things like a blank page. Some hosting companies will do this so that even if there are errors in applications, their customers won't see them and therefore they won't get as many support requests. Other companies do it because they just don't know any better.

    Either way, the only way to figure out what's going wrong is to go into the file and add echo('test');. Then run the script and see if it echos. Then keep moving that echo statement down in the file until it stops coming out. That way you can identify which line actually causes the script to hault. My guess is that it will be somewhere between line 127 and 165.
  • Options
    edited July 2006
    Tagging on here, but I can't get past stage 1 - and yes it is a new installation, not an upgrade. Getting this problem: "Vanilla seems to have been installed already. You will need to remove the conf/settings.php, conf/database.php files, and all database tables in order to run the installer utility again." I keep removing these files (there is no database created) and having another go, but it produces the same result? MySQL 4.1.15 EDIT: now getting - Precondition Failed The precondition on the request for the URL /PMS-Forum/setup/installer.php evaluated to false.
  • Options
    MarkMark Vanilla Staff
    Hmmm. Sounds like it could be related to this: http://wordpress.org/support/topic/33906
  • Options
    Thanks Mark - looks on the face of it like a TextDrive issue - I'm trying to get to the bottom of it...
  • Options
    Right, fixed it. For a start I didn't have an .htaccess file for my subdomain, so put one in then; from the TextDrive Help Desk - http://help.textdrive.com/index.php?pg=kb.page&id=85 12.18. Disabling mod_security If you’re seeing a lot of “Error 412: precondition failed” errors, it’s most likely the result of something triggering a rule in mod_security. TextDrive uses mod_security to block comment and referrer spam, but sometimes it get’s triggered by mistake. This can happen if something on your site (like a URL) matches a common pattern (like ”-poker”, ”-pictures”, or ”-sex”). A quick way to resolve this is to put the following in a .htaccess file in your public or public_html directory:SecFilterEngine Off Inserted that and cleaned out the newly created conf/settings.php and conf/database.php files and bingo all go now.There must be something in Vanilla triggering this with TextDrive, as the rest of what constitutes this site was OK, but now mod_security is disabled I am no longer protected from referrer and comment spam... so I'll have to troubleshoot - as they say! Thanks for pointing me in the right direction Mark.
  • Options
    MarkMark Vanilla Staff
    No problem! Glad you got it sorted out :)
  • Options
    To round-off, the problem was with the setup/installer.php Therefore, add this to the .htaccess file: SecFilterEngine On SecFilterSelective "REQUEST_URI" "/pms-forum/setup/installer.php" "allow,nolog"
  • Options
    This software is still in beta.
This discussion has been closed.