Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Solved] Problem with gdn.url()

edited August 2013 in Vanilla 2.0 - 2.8

Hi all,

We installed last revision from Github for testing purposes, and now are experiencing a rare problem. For example, with the Quote plugin. The plugin get the comment via GET with gdn.url('/discussion/getquote/'+ObjectID); well, this works fine, but.. its trying from the main domain, and not from the subdirectory.

The web is in:
And the forum in:

Well, the script is trying: discussion/getquote/Discussion_XX?format=Html instead: forum/discussion/getquote/Discussion_6?format=Html

This problem is the same if we enable jsConnect or other plugin using gdn.url(). The installation is fine, and detect the forum is in /forum. any ideas?

PS: The function is here:

For some reason, deleting the cache and the problem is fixed. Mark as solved, please :P

Sign In or Register to comment.