Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Solved] Strange behaviour of the tags

edited September 2013 in Vanilla 2.0 - 2.8

This question is about tagging the posts. It doesn't allow me the post more than 5 tags and if I use more than one word (for example I may need to write the title of a movie, book or anything else), it splits the words of the sentence and is considering them as different tags. And in this case I cannot post the discussion as I have more than 5 tags. Can you help me in this situation so that I can place more than 5 tags and more than one word in a tag? Thank you

Tagged:

Comments

  • I forgot to mention that I have installed these plugins that are related to the tagging process: "Tag Cloud" and "Tagging". Do you think one of these plugins may give me this headache?

  • It isn't a strange behaviour, it is by design if you use more than one word you use -
    e.g. two-words

    Try search the forum these question are often answered
    http://vanillaforums.org/discussion/comment/135716#Comment_135716

    grep is your friend.

  • I added one of those lines (Configuration['Plugins']['Tagging']['Max'] = 10;) and then the other one ($Configuration['Plugin']['Tagging']['Max'] = 10;) in config.php under // Plugins. I didn't receive the message that I have more than 5 tags. The problem is that only one of the tags was posted. What did I do wrong?

  • at least specifiy your version of plugin and vanilla.

    there are multiple versions of each and it is impossible for anybody to guess.

    there are a couple of tutorials on posting etiquette and almost daily if anyone reads a message. The question is what is your version of plugin and what is your version of vanilla.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Vanilla version Version 2.0.18.8.

  • I don't know what plugin causes the problem. As I said , I tried to add the lines in config.php but it didn't work.

  • peregrineperegrine MVP
    edited September 2013

    repeat:

    • at least specify your version of plugin

      (i.e. was it the enhanced version or did it come with core vanilla) the version of the plugin will tell us.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • So, these are the plugins that are related with tagging: "Tag Cloud" v 0.1 and "Tagging" v 1.1p1

    I don't know if I answered to your question.
    From the beginning I couldn't add more than 5 tags but this is the first time I decided to change that.

  • peregrineperegrine MVP
    edited September 2013

    I tried this.. with the enhanced tagging plugin

    $Configuration['Plugin']['Tagging']['Max'] = 10;

    I read the description and followed the instructions and installed
    http://vanillaforums.org/addon/tagging-plugin

    I also made these changes

    http://vanillaforums.org/discussion/24911/code-256-exception-table-db-gdn-discussion-doesn-t-exist#latest

    and it worked for me. i added 6 tags for example.

    I don't have
    "Tagging" v 1.1p1

    if its on github - due to my computer and internet limitations, I cannot download zipped files or use github. period! so I can't do anything that requires retrieval from github or using it. so I can't test it. github is not friendly, if you have a slow internet connection. nor does it give retries on curl or wgets.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • $Configuration['Plugin']['Tagging']['Max'] = 10; - where did you add this line?

  • peregrineperegrine MVP
    edited September 2013

    $Configuration['Plugin']['Tagging']['Max'] = 10; - where did you add this line?

    in /conf/config.php where the other lines start eith ['Plugin'] - but location doesn't really matter. just makes it more readable and usually things sort themseleves out anyway on the next config change through the dashboard.

    one day when you have the time, you will take a day and search the forum and read documentation provided as links in other discussions. it will enlighten you.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I got that message regarding the GDN (or something like that), then I tried to make those changes, I couldn't find the right files so finally I disabled the plugin completely. I will use the forum without tagging. I will wait till there appear smart plugins for dumb people like me. Thanks for your time.

  • peregrineperegrine MVP
    edited September 2013

    I tried to make those changes, I couldn't find the right files so finally I disabled the plugin completely.

    • the main trick with computers and programming is not to give up!

      • changing things may consume alot of your time causing frustration (take a break and try again when your mind is fresh).

      • changing things requires exactness and following instructions to a T

      • finding the right files requires matching the filename in the instructions with the files in the plugin folder. Usually the number of files in a specific plugin folder is usually 5 or so, it is not really to complex to match the name in structions with the filename on the computer.

    Thanks for your time.

    you are welcome.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinderUnderDog
  • It seems that it finally worked. I did all those changes and no messages appeared and I could set more than 5 tags. I had to listen a song to calm down and then I started again. Thanks again.

    hgtonightUnderDog
  • peregrineperegrine MVP
    edited September 2013

    cheilenereinfo said
    It seems that it finally worked. I did all those changes and no messages appeared and I could set more than 5 tags.

    I had to listen a song to calm down and then I started again. Thanks again.

    oddly enough - I also have to listen to a song sometimes to calm down when responding to questions :).

    glad it worked.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinderUnderDogR_J
  • Yeap. Thanks for your time

Sign In or Register to comment.