Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Not visible in 2.1.b2

Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

Hi, VrijVlinder... ;)

I'm using 2.1.b2 with the newest Opera/Firefox.
After deactivating my in usual use CLEditor and activating your TinyMCE Plugin, it doesn't show anything but the basic Editor of Vanilla.
Do i have to do something else to activate it? ThX ;)

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Have you looked in web inspector to see what files are loading or not ? do you have javascript enabled ?

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited November 2013

    Web inspector is for Apple, right?? Don't have the Fruit.. ;)

    Yes, Javascript is enabled... I also tried it on a Tablet, same problem there...

    I looked into Firebug, all I can see is the normal TextBoxWrapper Div... TinyMCE seems not to be loaded, but i realy don't know how it should look like... ;)

    If you like to look:
    http://caba.de/CaBaFoRuM/index.php?p=/discussions

    Name= testuser
    Passw= testuserpass

    I also tried the default Theme +Baseline... same there...

    Thanks in advance... ;)

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    p.s.: TinyMCEFour is avtivated, CLEditor deactivated

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You should try setting Rewrite URL True in the config. The editor javascript is being called. You may need to download the german language pack from tinymce website.

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    YES! Found it... ;)))

    It wasn't the Language Pack or the Rewrite URL, it was a simple Typo:

    In search for:

    $Sender->AddJSFile('plugins/TinyMCEFour/tinymce.js');

    Change to:

    $Sender->AddJSFile('plugins/TinyMCEFour/tiny_mce.js');

    Please check this in your Plugin, vrijvlinder.. ;)

    Thanks for helping, i hope that your Plugin is correcting the issues that I have with CLEditor... ;)

    vrijvlinder
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Thanks for figuring it out new version being uploaded asap.

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited November 2013

    If you like you can wait for a bit, cause there are more issues I found, but i can test them only in deep dark nights.. ;)

    Some quick findings, that I have to do some more testing:

    1. German Umlaute not shown " ö ä ü ß "

    Found this solution in TinyMCE Forum:

    entity_encoding : "raw"

    but where to put it??

    1. Full, Advance, Simple settings in init.js not working (allways shows... i think "Advanced")
    2. Emotify: Emoticons are not inputted on Cursor position (thats one of my reasons to switch from CLEditor)

    Also this quick one:

    in all this Functions (in "class.tinymcefour.plugin.php"):

    private function _simple()

    private function _full()

    private function _advanced()

    there is always this Code:

    // General options

    theme : "advanced",

    Schouldn't it be "simple", "full", and "advanced" each?

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited November 2013

    Ok, did some cleaning up in the Code (see attachment)

    There where some mixups with "simple", "advanced" and "full"

    I also found the place to put "entity_encoding : "raw" " to enable german umlaute (öüä)

    Please check it, because i did it all with "try and Error", not with Knowledge... :D:D:D

    There seems that the "full" theme is lacking in the Theme folder...

    Still working on it, but maybe you can help me with this one:

    The Button bar shows beneath the Editor... how to put it on top??

    (see Picture)

    ThX for helping.. ;)

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    OK, I changed the "Advanced" function so it shows only the Buttons i need.. ;)

    I see that Emotify is not necessary, cause Tiny has it's own Smileys that I can change AND they are placing themselves to the right cursor position!!

    Another serious problem:

    When the Editor is visible, no Dropdown Menus are working!! For example try to open the Dashboard or try to Edit a previous post.... really obscure...

    Also the Videolinks/Videoplayer is not working... it shows the Player/Startimage, but klicking on it does nothing...

    you can try it if you like:

    http://caba.de/CaBaFoRuM/index.php?p=/discussions

    Name= testuser Passw= testuserpass

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You have an error in your site

    < script >(function() {with (this[2]) {with (this[1]) {with (this[0]) {return function(event) {return false;
    };}}}})< /script >

    You are trying to load an index.php in a stylesheet.

    Look inside tour filemanager in the css section, somewhere you have a file that should not be there.

    When I try to post There is a pop up but I can see anything in it. Unless you have not given me permission to post. I can't test it. But look for that index.php file that is being called as a style sheet, so look in all your css folders to find it and move it.

    tiny.png 137.4K
  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Uh... I tried all the night Yesterday to find that error... no luck... ;(

    Did I understand you corretly? In a Stylesheet should be an "Index.php" ??

    I searched for "index.php" with a program, that searches the content of files (all files of my Vanilla Forum), ... no luck...

    I installed other Developer plugings for Firefox, did got some styles warnings, but nothing serious...

    I am shure, that If there is such an error, it wasn't me... ;)) I looked into my CSS Files, everything is OK.. ;)

    In the Attachment Pictures you can see, what dropdowns are not working anymore:

    image

    Also the PLAY BUTTON (and just the Button) of the youtube Player is not reacting...

    I think that this is a strange Javascript error, or somekind of incompatibility, when TinyMCE is loaded...

    If I enable CLEditor, I do not have these Issues anymore...

    If you like, try to put some text here into the Forum:

    http://caba.de/CaBaFoRuM/index.php?p=/discussion/2508/das-neue-cabaforum-tipps-test-und-hilfeseite#latest

    Name= testuser Passw= testuserpass

    testuser has the normal user privileges, as all of my users..

    After saving your entry, try to edit it...

    I asked also my users, they have the same issues as me...

    This "small" error stands between me and a happy CaBa Community... Sooooo close yet so far away... ;))

    ps.: I did of course tried it with:

    Standard Baseline+ Theme
    Opera
    Firefox
    Chrome
    Tablet Browser
    Other Users

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    I think maybe another plugin is interfering, I don't have these problems in my 2.1 install. Maybe disable them one by one and test.
    I can't seem to be able to post on your forum, you need to give me permissions to post.

    UnderDog
  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    I think I have to give up... ;(

    Removed ALL Plugins, still no luck... looked into the JS Files... I think I could learn Chinese quicker... hehe... ;)))

    I think I have to wait for another Version, hopefully the problems will disappear... ;)

    What I did now is go back to CLEditor, downloaded the newest Version from the CLEditor Website and exchanged it with the Vanilla one...
    Seems to be working, no Letter conversion errors any more... ;)

    The only Issue that I have left is, that the Smileys from the Emotify plugin are not placing themselves on the Cursor position.. ;)

Sign In or Register to comment.