Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Drop in recplacement?

This discussion is related to the SphinxSearch addon.

In what universe? There are files and folder that the instructions says needs permission yada yada and those files don't even exist, the installer is a joke since it doesn't autodetect the right directories or files, perhaps take a closer look at the directions and at least make sure the latest build has all the directories and files that are stated in the directions.

«1

Comments

  • peregrineperegrine MVP
    edited November 2013

    @lxle

    you always have the ability to post your changes, fixes, whatever.

    if your goal is to get it working. Try manually installing manually via sphinxsearch website.

    starting from this comment.

    http://vanillaforums.org/discussion/comment/196375/#Comment_196375

    perhaps you could write an improved set of instructions and provide whatever fixes you think to @mcu_hq

    that said,

    "the installer is a joke"

    this doesn't engender good feelings by volunteers who have provided good plugins for free.
    I suggest you make a donation or hire @mcu_hq and if your server environment allows it, I'm sure he could get it working for you.

    albeit - the install is a bit tricky and you really need to know what you are doing to install it, and "you" have a good comprehension of finding processes and daemons and ensuring they are working.

    it does - however once the plugin is operational in your environment - it is a fantastic plugin.

    if you got a problem with a plugin. Generally it is a good idea to state your server environment, the version of vanilla, the plugin version and the steps you took and where you ran into an issue..

    as much as your other points may be valid or not. constructive or not.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • understood, frustration got the best of me, but considering all the post in the forums, i'm far from the only one that struggles with this plugin, which, in their words not mine, is a drop in replacement, perhaps drop in means different things to different people.

    peregrineUnderDoghgtonight
  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭

    @peregrine already pointed out some valid things as always :).

    The installer is tuff to get working because of different server configurations and read/write permissions with your apache config, which is why I recommend that you install using your distro and then copy past paths to the installer.

    Try getting sphinx installed and working from their example files first on your server.

    UnderDoghgtonightperegrine
  • @lxle sphinx is advanced. It is not some drop in. It is serious infrastructure.

    My advice to @mcu_hq was to take out the sphinx bundle from this plugin becuase really it is the responsibility of the server tech to set the up on their on their platform. He is just asking for abuse for trying to be helpful in the first place, when really it isn't worth it the plugin folder is not a good sandbox for sphinx even if the installer works.

    9/10 it is better to install from scratch something like this.

    Let put in perspective. sphinx is something like installing a server or a database engine. Vanilla is much higher up the server stack.

    Also regarding files, etc. I discourage file management by scripting anyway, unless it is something you run on the console as an admin tool.

    grep is your friend.

    UnderDog
  • This is why I sponsored the SphinxSearchLite plugin. Install through your distro, drop the addon in, generate a config file, copy it to your Sphinx folder, job done.

    hgtonightUnderDogShadowdare
  • hbfhbf wiki guy? MVP

    i've got it running. it's light years ahead of the default search - which is the real joke.

  • @hbf said:
    i've got it running. it's light years ahead of the default search - which is the real joke.

    it is just the wrong took for the job. But you can't expect something like sphinx out of the box.

    grep is your friend.

  • businessdadbusinessdad Stealth contributor MVP

    @x00 said:
    lxle sphinx is advanced. It is not some drop in. It is serious infrastructure.

    I agree. I'm working on implementing something similar, using ElasticSearch instead, and I won't even consider handling the installation of the ES server. The plugin, if and when will be completed, will simply ask for the address of the ES server cluster. How that is installed, maintained, configured, etc will be up to the Sysadmins.

  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭
    edited November 2013

    The installer is actually based on the sphinx WordPress plugin. I'll branch the current full-featured plugin and then remove all install stuff in the trunk moving forward. This way it will force people to read the sphinx docs on how to install and setup. The plugin won't check for the existence of sphinx and will simply echo out any errors directly from the sphinx API....essentially what SphinxSearchLite is already doing.

  • @mcu_hq said:
    This way it will force people to read the sphinx docs on how to install and setup

    I think your idea might save yourself alot of abuse and headaches. and the onus of sphinxsearch installation will be placed in the forum admin. and your great plugin will take care of the rest assuming forum admin can and does install the distro properly and tests prior to using your plugin.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭
    edited December 2013

    Alright I stripped the packaged installer and the dashboard admin controls out of the main release. Three paths now exists:

    1. Master
    2. Lite
    3. Installer

    People wishing to give the auto-installer should try the installer branch. The lite version was somewhat custom made for a sponsor. It is similar to the Master in some ways, but does not contain all of the widgets, stats index, and has different options in searching. The github readme files have more info.

    peregrinehgtonightliyimingcss
  • meshugymeshugy Musician/Hacker ✭✭

    @50sQuiff said:
    This is why I sponsored the SphinxSearchLite plugin. Install through your distro, drop the addon in, generate a config file, copy it to your Sphinx folder, job done.
    @50sQuiff said:
    This is why I sponsored the SphinxSearchLite plugin. Install through your distro, drop the addon in, generate a config file, copy it to your Sphinx folder, job done.

    I installed Sphinx on my server and got the Sphinx plugin to find indexer, searchd, and the config file, but I can't get it to create the new config file. I'm stuck with the default one which tries to look for a test database. Any ideas what I'm doing wrong? I think if i got the updated sphinix.conf file then I'd be able to index my database.

    I'm using Sphinx with Vanilla 2.12b

    thanks....

  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭

    @meshugy I'm still working on the plugin to work for 2.1b. The installer just needs a few tweaks for compatibility. Also the wizard will no longer look for such paths. Instead, you just copy and past your sphinx.conf file into the wizard. This should get rid of the read/write problems that you are most likely having. I'll hopefully get it done and tested today.

    hgtonightopenletter
  • meshugymeshugy Musician/Hacker ✭✭

    @mcu_hq thanks in advance for the update!

    I have a few other questions:

    What should the configuration prefix be set for? I just left it as vss_ but let me know if it should be set differently.

    Is there only one page to the wizard? I entered the configuration prefix, port, and host and hit save and it just reloads the same page. I got the feeling from reading other posts that there is another section to the wizard, am I wrong?

    Thanks....

  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭
    edited December 2013

    I entered the configuration prefix, port, and host and hit save and it just reloads the same page

    Yea, there were some subtle changes in v2.1b that prevent you from advancing.

    The prefix can be any string. I use it to distinguish between the plugin's indexes from any other potential indexes in your sphinx.conf file. For example, if you are already using sphinx on your main site and have already created an index called, "discussions", then you don't want the plugin to overwrite this index. In short, the prefix is creating a namespace.

    The second and last required step is pasting your configuration file into the wizard. You'll see later today when I get it working on 2.1b. This is pretty much it though.

    hgtonight
  • meshugymeshugy Musician/Hacker ✭✭

    great, I eagerly await the new version!

  • meshugymeshugy Musician/Hacker ✭✭

    @mcu_hq one thing I noticed is that the current Sphinx plugin interferes with the Quotes plugin when using 2.1b2 When you try to quote someone it just come up blank. I turned Sphinx off at the quotes worked again.

    UnderDog
  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭
    edited December 2013

    @meshugy Download this zip and extract it to your plugins folder and rename it to SphinxSearch. It includes the latest of the plugin that I've got working with v2.1b. I haven't come across this quotes problem though. My testing was not that exhaustive, but I didn't see any problem with quoting people while the plugin was enabled.

    If you get an error inside of UserModel, delete your cache folder and do a refresh. This is so that the framework sees that sphinx is overriding the search model.

    meshugy
  • meshugymeshugy Musician/Hacker ✭✭

    @mcu_hq thanks for the update! I was able to create the conf file but when I ran searchd I got these errors:

    WARNING: key 'port' is deprecated in /usr/local/etc/sphinx.conf line 237; use 'listen' instead.
    FATAL: failed to create pid file '': No such file or directory
    

    Any ideas what's wrong?

  • meshugymeshugy Musician/Hacker ✭✭

    The conf file that your plugin created didn't set a location for the pid file:

    <br />searchd
    {
        port            = 3306
        log             = 
        query_log       = 
        pid_file        = 
    
  • meshugymeshugy Musician/Hacker ✭✭

    ok, filled those in like this:

    searchd
    {
        port            = 3306
        log             = /var/log/searchd.log
        query_log       = /var/log/query.log
        pid_file        = /var/log/searchd.pid
    
    

    Now I get this error:

    WARNING: key 'port' is deprecated in /usr/local/etc/sphinx.conf line 237; use 'listen' instead.
    listening on all interfaces, port=3306
    precaching index 'vss_main'
    WARNING: index 'vss_main': preload: failed to open vss_main.sph: No such file or directory; NOT SERVING
    precaching index 'vss_delta'
    WARNING: index 'vss_delta': preload: failed to open vss_delta.sph: No such file or directory; NOT SERVING
    precaching index 'vss_stats'
    WARNING: index 'vss_stats': preload: failed to open vss_stats.sph: No such file or directory; NOT SERVING
    
  • meshugymeshugy Musician/Hacker ✭✭

    I think I need to run the indexer first, I tried that and got this error:

    FATAL: failed to open vss_main.spl: Permission denied, will not index. Try --rotate option.
    
  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭
    edited December 2013

    nice! ok, I found the error in the plugin in relation to the paths not being set. You can either:

    1. Run the wizard again to see the file paths populated correctly
    2. Download the small bug fix and disable/re-enable the plugin after you transfer the files over. The wizard should work on your first iteration through it
  • meshugymeshugy Musician/Hacker ✭✭

    thanks, the new version created the correct conf file.

    But not I'm having some sort of permissions problem when I run the indexer:

    FATAL: failed to open vss_main.spl: Permission denied, will not index. Try --rotate option.
    

    Where is vss_mail.spl located? I can set permissions once I know that.

  • meshugymeshugy Musician/Hacker ✭✭

    Never mind, I had to run the indexer as sudo and it worked!

  • meshugymeshugy Musician/Hacker ✭✭

    Now when I search on the site i get this error:

    Query failed: failed to read searchd response (status=2613, ver=11825, len=775108909, read=68). 
    

    Any idea what the problem is now?

  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭
    edited December 2013

    Alright cool. Let me know if you run into any issues with 2.1b. I've been using sphinx v2.0.5. It looks like you are using sphinx v2.1.x....but I don't expect any issues.

    Keep in mind that any new content that you add will not show up in any sphinx-related material until you index again. You should index the delta one often and the main one not so often since it may take a long time depending on the size of your site.

    Now when I search on the site i get this error:

    Ahh....I think it is because the sphinx.api that I package with the plugin is from v2.0.4 and you are using a later installation of sphinx! For now, you should simply copy over the PHP API file that comes with your version of sphinx and copy it over the one that is being used in the plugin.

    I'll add this note to the install portion of the readme.

  • meshugymeshugy Musician/Hacker ✭✭

    ok, i tried copying the api from my version of sphinx into the sphinx plugin folder, now I get this error when I search:

    Query failed: connection to localhost:9312 failed (errno=111, msg=Connection refused). 
    
  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭
    edited December 2013

    Yes, I would expect that error after looking at what you posted above: listening on all interfaces, port=3306

    Your config file should have written the searchd { port = 9312 ... }. It looks like you are trying to connect to a port that searchd is not listening on. Can you go through the wizard one more time and ensure that your generated config file has the port = 9312 under searchd part? If it is, then restart searchd

  • meshugymeshugy Musician/Hacker ✭✭
    edited December 2013

    ok, i redid the wizard and uploaded the conf file. Now when I run the indexer (as sudo) I get this error:

    FATAL: failed to open /var/data/vss_main.spl: No such file or directory, will not index. Try --rotate option.
    

    any ideas? I got it to run before with a different conf file.

«1
Sign In or Register to comment.