Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

cannot activate extensions

outbreakoutbreak New
edited July 2006 in Vanilla 1.0 Help
i installed the new release of v1, downloaded all the awesome extensions i wanted to use, uploaded them to my server, and then tried to check the box to activate them. when i check the box, nothing happens and the extension does not activate.

what could be wrong?

edit: also it seems that the "you have not checked for updates" message will not go away after my updated install.


  • aaa have you checked your chmod? that may cause the extensions not to isntall and the checked for updates gets stored in a file. thats all i can think of.
  • everything seems fine. is it a cookie problem perhaps?
  • nah it cant be, as the checking for updates things saves it all in settings file of when you last checked and such. And the extensions saves what has been activated to extensions.php somewhere. It must be something like chmod issues.
  • actually, i just tried it in a different browser after clearing my cache and history, and it seems like it was in fact a cookie issue. the extensions turn on now, i'm not sure why that would make a difference. the updates message still did not go away though and i checked all the folder access info to make sure everything was ok. very odd.
  • oo i dont know then, thats ver strange. Better wait for someone who knows what they are doing :P
  • MarkMark Vanilla Staff
    When you check for updates, a setting is added to your conf/settings.php file that contains a timestamp indicating when you checked for the update. The update reminder message then looks at that date and how often you want to be reminded when deciding to appear or not.

    If you check for updates and the message doesn't disappear, I'd bet dollars to donuts that your permissions aren't working properly.

    Now, Vanilla is written so that it *should* catch those errors, but depending on different server settings and configurations, it may fail to do so (as it appears to be doing in your case). Typically I will put @ symbols in front of php functions that cause nasty error messages. That will allow the error to happen without reporting any problems. Then I'll check to see what the outcome of the function was by it's return variable or by looking at the $php_errormsg variable (Which contains the last error message to occur) and report a problem based on those. Sometimes those values don't return anything that indicates an error - and that is when things appear to work properly, but don't.

    The offending code in this instance is in library/Framework/Framework.Class.ConfigurationManager.php:

    function SaveSettingsToFile($File) { // Open for writing only. // Place the file pointer at the beginning of the file and truncate the file to zero length. // If the file does not exist, attempt to create it. $FileContents = $this->UpdateConfigurationFileContents($File); if ($this->Context->WarningCollector->Iif()) { $FileHandle = @fopen($File, "wb"); if (!$FileHandle) { $this->Context->WarningCollector->Add(str_replace("//1", $File, $this->Context->GetDefinition("ErrOpenFile"))); } else { if (!@fwrite($FileHandle, $FileContents)) $this->Context->WarningCollector->Add($this->Context->GetDefinition("ErrWriteFile")); } @fclose($FileHandle); } return $this->Context->WarningCollector->Iif(); }

    If you want to figure out what's wrong, the easiest way I can think of is to remove all of the @ symbols in that function and then go try to do an update check again. If the server encounters any errors when trying to write to the configuration file, they should be barfed onto the screen so you can figure out exactly what's going wrong.
  • great, thanks mark. i'll figure it out.
  • MarkMark Vanilla Staff
    Keep posting on here so others can see if/how you resolve it.
  • well, i completely cleared my cache, history, and temp files and that seemed to clear up the extensions issue. not really sure why that would have an effect. after i disabled the updates and then re-enabled it, it started to work properly. the only thing that seems strange is that after fixing the update reminder and i click "check for updates," i get the following message:

    "You are not running the latest version of Vanilla.

    Because you are using a pre-release, all you need to do is download the Vanilla package and copy the new files on top of your existing files. You do not need to run the upgrade procedure on your installation of Vanilla.

    You can download Vanilla from"
  • I have the "you are not running the latest version of Vanilla" message still, too. I think the main reason is what I did: I backed up my files before deleting them from the webserver and uploading the latest version. I followed the procedure where I renamed my /appg/settings.php file to old_settings.php and uploaded it to the /conf folder. When I tried to upgrade to the the pre-release to the current version, it would send me to the folder /setup/setup/index.html. So, I just went back and put the old old_settings.php that was in my backed-up /conf folder into the new /conf folder. This time, the upgrade went as planned, but since I just used the old old_settings.php file I had before, it was still reading that I had the pre-release version. I hope that makes sense. I guess the question for me is, how to fix that error that sends me to /setup/setup/index.html folder?
  • MarkMark Vanilla Staff
    I had made a mistake in the update check script on If you check now it should tell you that you are up to date...
  • Thanks, Mark!
  • I couldn't activate my extensions so I cleared the cache & history and now I cannot even sign in!!! I upgraded from 0.9.2
  • MarkMark Vanilla Staff
    If you can't activate extensions, then you've got your permissions set up incorrectly on the conf folder.
  • Why can't I signin? Why does the signin link just refresh the page? Something is wrong with people.php I think.
  • Hey Bozzy we get that you have a problem but come on stop writing the same thing into every thread remotely related.

    Check your file permissions for the different directories and sub folders also check the owner of the files, if that doesn't seem to work restore your backup and go back to and give Mark and the guys a chance to figure it out.
  • edited July 2006
    I've checked the permissions of every file the upgrade process told me to check... and they are correct.. something else just went wrong... I turned off 'public browsing' of the forum and now the browser won't even connect to my site... Does anybody have anything to say or are they just going to ridicule me? <blockquote> Firefox has detected that the server is redirecting the request for this address in a way that will never complete. </blockquote> Locked out again!
  • Try it with IE, sounds funny but I had a problem that in FF I could not get some features to work the AJAX stuff was just not working properly. In IE though it was working and I was able to set some config stuff and now I can use FF normally.
  • I just looked at your site and it's just an advertising site. Is this correct?
  • MarkMark Vanilla Staff
    I've started a private discussion with bozzy and I'll get him sorted out.
This discussion has been closed.