Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

vanilla 1 - language file

edited July 2006 in Vanilla 1.0 Help
I've upgraded my 0.9.2 forum to version 1 and changed a few settings (enabled whispers and turned on the IP logging) and suddenly, almost all of my threads are marked as unread. A few of them are marked as read but totally random. What could be the problem? And if there is no solution, Is there at least a "mark all threads as read" function that I'm not aware of? Thanks in advance.

Comments

  • Options
    there is an extension to mark all threads read yes as far as i am aware.
  • Options
    Nevermind, it just fixed itself automagically. Now I have another question.. I don't have the choice to format my comments when I'm writing a post. It's correctly set in my "forum preferences". What could be the problem here?
  • Options
    edited July 2006
    (( Or maybe I am way off.. I've installed the "quotations" extension and it doesn't work since I can't choose neither HTML nor BBCode. Do I have to install the BBcode extension first (and which one)? So confused. :( )) Nevermind this, didn't read the extension description. :) n00b
  • Options
    edited July 2006
    One more question.. sorry for flooding but I have to make this work in a short notice. I understood that I need the "better bbcode extension" to make the quotations work with bbcode, but the old BBCode extension had the option to always have the "BBCode" format selected when writing a post, and this one doesn't. How can I do that?
  • Options
    MarkMark Vanilla Staff
    In Vanilla 1 it should always remember what you last checked for the comment format. So, right now if I choose Html and click to add my comments, it will remember what I chose and automatically have Html selected the next time I go into any discussion or click to start a new one. Alternately, if I choose text formatting, it will always have text formatting selected automatically.

    So, to have bbcode always selected, just choose it and post a comment. It should remain checked from then on.
  • Options
    I don't want my users to do this though, is there a way to not have the option by default but keep BBcode always selected instead of having the option turned off in settings yet having plain text comments?
  • Options
    MarkMark Vanilla Staff
    So you *only* want then to be able to use bbcode?

    You'd have to write an extension to do it, but it's possible, yes.
  • Options
    Good job, Mark, that's great. :) I'll post to this thread if I run into any more troubles. Thanks.
  • Options
    Yet another issue. :) Is there some kind of a changelog for the language file? I translated it for 0.9.2 but the new file seems significantly different so..
  • Options
    @lowbenzo:
    You might be able to edit the Better BBCode extension. All you'd have to do is find the place where it adds radio buttons, and make that hidden (I think). Actually, I'm not sure that'd work, but it might! :)
  • Options
    bump.
  • Options
    MarkMark Vanilla Staff
    There used to be a huge changelog for the language file, but when the change log got bigger than the file itself, I just removed it and kept making my changes. Sorry :(
  • Options
    Not a big deal, I'll just do it again then.
  • Options
    '@lowbenzo: You might be able to edit the Better BBCode extension. All you'd have to do is find the place where it adds radio buttons, and make that hidden (I think). Actually, I'm not sure that'd work, but it might! :)' Will give it a try!!
This discussion has been closed.