Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade here. These earlier versions are no longer being updated and have security issues.

500 error (Bonk) when logging in with Google

I'm setting Vanilla up for the first time. When logging in via Google, inside the popup, after choosing a login ID, I get a 500 Internal Server Error. Looking at my error logs, it appears the response was blank?

[Fri Nov 29 14:31:20.781319 2013] [:error] [pid 55788:tid 680605952] [client 172.17.0.142:41543] End of script output before headers: index.php, referer: http://vanilla.mydomain.com/entry/connect/openid?display=popup&Target=/&openid.ns=http://specs.openid.net/auth/2.0&openid.mode=id_res&openid.op_endpoint=https://www.google.com/accounts/o8/ud&openid.response_no...

OpenID also fails in the same way when I try it with https://www.google.com/accounts/o8/id

Could this be some kind of permissions issue? Is there a script that's failing to execute somewhere?

I also noticed that entering an invalid OpenId url results in an ugly "Fatal Error in LightOpenID.request();" error (Bonk), but I'm not sure if that's related or if these plugins are just a bit on the untested side.

Comments

  • script output before headers: index.php is usually an indication there is some stray white space somewhere, or some premature output.

    sometimes some add-ons add extra white space without realising or they echo something for crude debug reasons. The most common mistake is adding an unnecessary ?> at the end of a file with stray white space after.

    What you could do is one by one disable add-ons an try it.

    You definitely haven't touched any core files?

    grep is your friend.

    UnderDog
  • I disabled my other plugins (Twitter, Facebook, Gravatar) so only OpenID and Google Sign In are left. It's a stock install from this morning, the only change I've made to any file is to chmod a 777 couple directories add error checking to config.php (and that's been reverted).

    I tried a fresh install on my local system. Tried to create a new account with Google Sign in, got a bonk (I forgot to configure errors first) in the same place. Subsequent tries keep telling me "You already have an account here." and ask for the password for the account I just created, which afaik doesn't have a password. This seems to be a completely different problem, but its hinting that I should probably drop this for now and try again when it's more stable.

  • The stability isn't the problem. You could help by not saying : "I have a BONK error", Period, but by saying "I have a BONK error and here are the details"

  • I would chmod 777 anything there is never any reason to set permission that high.

    Fist check that meet the minimum requirement. I presume you a have curl installed.

    Then follow this
    http://vanillawiki.homebrewforums.net/index.php/Bonk_Errors

    grep is your friend.

  • UnderDog: I can't get the BONK details because like I said it only happened once, while I had error messages turned off.. oops! Now it keeps asking for my nonexistant password instead. I expected it to create a new Vanilla account when I logged into a different Google account, but the password prompt for the original account persists.

    x00: Yup, min requirements all in place and I'm running WordPress and phpBB on the same server. Vanilla asked me to make the cache, conf, and upload dirs writable. They started as 775; adding the write bit made them 777. What should I have done instead?

  • To be thorough, I tried a fresh install on my local WAMP server and errors turned on so I could see that first BONK which caused the password prompt. Problem was Fatal Error in PHPMailer.MailSend(); Could not instantiate mail function. Oops! That's right my local computer has no mail server, and though it is not a requirement for Vanilla it must be for the Google Sign in plugin.

    My production server, the one I'm trying to debug, does have mail and it's working. I also tried a new fresh install there but had the same results as before (End of script output before headers). Twitter and Facebook logins do work, just not Google or OpenID.

  • @sarahnorthway said:
    End of script output before headers

    Switch to the default Vanilla theme

  • PHPMailer is bundled with vanilla it required fsockets and allow_url_fopen to be On.


    if there is already an account it the connect has to link it. it is likely the root users password you'd try.

    basically this will happen every time there is an unlinked account wit the same email.

    grep is your friend.

    hgtonight
Sign In or Register to comment.