Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Page not found when going to /messages/inbox*

ENZYMENZYM New
edited December 2013 in Vanilla 2.0 - 2.8

Hi guys,

I think I'm being a bit stupid here but my private messaging isn't working. My theme has an inbox which takes me to /messages/inbox but all I get is a page not found error :/ can anyone help?

Comments

  • Options

    Take a look in your conf/config.php and see if you find Messaging in your enabled applications

    What does your .htaccess look like?

    There was an error rendering this rich post.

  • Options

    There is no Messaging section of my config.php and my .htaccess is default.

    Thanks for the reply.

  • Options
    ShadowdareShadowdare r_j MVP
    edited December 2013

    Under the // EnabledApplications section in your /conf/config.php file, add this line to enable the private messaging features:

    $Configuration['EnabledApplications']['Conversations'] = 'conversations';
    

    You can also go to your admin dashboard and go to the "Applications" settings page, which can be found in the admin dashboard's sidebar under the "Addons" section (http://example.com/dashboard/settings/applications), to enable the "Conversations" application.

    Add Pages to Vanilla with the Basic Pages app

  • Options

    All of that is already enabled and in the config but /messages/inbox still isn't working :(

    Thanks for trying :)

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    Please look at the tutorial for 404 error. Please post your htaccess file contents, and tell us if you have rewriteURL TRUE or FALSE.
    post link to your install please.

  • Options
    peregrineperegrine MVP
    edited December 2013

    @ENZYM

    I know that depending on the setting

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    or non-existent

    or
    $Configuration['Garden']['RewriteUrls'] = FALSE;

    had an impact on going to the inbox for a vanilla version.

    suggest you post your version and read the etiquette and how to post a question

    Let's follow the advices in the links first:

    http://vanillaforums.org/discussion/23130/forum-post-ettikett-etiquette

    http://vanillaforums.org/discussion/17954/food-for-thought-forum-etiquette

    http://vanillaforums.org/discussion/25115/how-to-how-can-a-new-user-better-help-the-community-when-asking-a-question

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    peregrineperegrine MVP
    edited December 2013

    @ENZYM

    I decided to search the forum ** inbox found**

    and i came up with something. what did you try doing after you searched the forum?

    http://vanillaforums.org/discussion/18920/inbox-not-found

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    @peregrine
    I'm running Version 2.0.18.9, apologies about that.

    I also apologise if my post isn't written up correctly, but I do find it slightly rude for you to grill a new member using vanilla forums - I literally started using Vanilla yesterday and also only joined the community yesterday, a few hours before I posted this.

    I'm afraid none of their fixes worked for me - my RewriteURLs is already set to false.

    I also did search about the problem but stupidly only on google rather than using the search on these forums, sorry about that.

  • Options

    So you searched, you googled, rewriteurls are set to 'false' (maybe the problem) and .htaccess is 'default' (maybe the problem).

    Time to do some debugging. You write down the address you try to access ...

    Messages should be the controller, inbox the 'action'.

    Try to find the controller file in the 'conversations' application.

    If you will ask 'how' I'm going to cry and since you find people politely showing you some etiquette rulesto read, I will turn back into 'Moderator Mode'

    In that controller file you need to look for the lines that say something like '404' or 'not_found' (it's a line that needs translation, so it's in a T() function call...

    Let's see if it helps ...

    There was an error rendering this rich post.

  • Options

    I'm just currently re-uploading all the files to a different domain on the host so I will get back to you after I've done that, thanks for helping.

    Sorry if you don't agree, I just found the links to the post etiquette a little patronising.

  • Options

    I just reuploaded all my files after changing my domain and for some odd reason everything has been fixed - no difference in uploaded files at all.

    Seems a bit odd, but fixed none the less, thanks to everyone who helped and commented :)

Sign In or Register to comment.