Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

HELP needed! messed up the web-path

edited July 2006 in Vanilla 1.0 Help
Hi, I just installed vanilla and changed the webpath in the settings to test that function. But now I can't access the whole thing anymore and trying to change the webpath back to the original webpath doesn't work since the files are looking at the wrong place!! Anyone knows how to fix this?


  • MarkMark Vanilla Staff
    edited July 2006
    Open up your conf/settings.php file and edit there manually... Look for the line:

    $Configuration['BASE_URL'] = '';
  • Hi Mark, thanks, I already tried that within the settings.php file that is in the directory called appg... doesn't work somehow? in the conf directory there is no such file do I need to chance all aother path/to/vanilla items as well? $Configuration['APPLICATION_PATH'] = '/path/to/vanilla/'; $Configuration['DATABASE_PATH'] = '/path/to/your/database/file.php'; $Configuration['LIBRARY_PATH'] = '/path/to/your/library/'; $Configuration['EXTENSIONS_PATH'] = '/path/to/your/extensions/'; $Configuration['LANGUAGES_PATH'] = '/path/to/your/languages/'; $Configuration['THEME_PATH'] = '/path/to/vanilla/themes/vanilla/';
  • I found the file... i needed to refresh my darn ftp browser, but i can't download it or edit it!
  • MarkMark Vanilla Staff
    As it says at the top of the file, you should never edit the appg/settings.php file. That file defines the configuration settings, but your customizations to those settings are applied in the conf/settings.php file. If you see something in the appg/settings.php file that you want to change, copy that line into conf/settings.php and edit it there.

    The reason for this is: when you perform upgrades to Vanilla, you can copy and paste the new files on top of the old ones and the appg/settings.php file will be replaced, but the conf-folder files will not.
  • hi mark i changed it all back in the appg file. thanks again for your kind help, but I can't retrieve, copy or change the settings.php file in the conf dir as that has been created by the server (apache) and is thus set to chmod 600. Maybe I'll just try a reinstall in this case. thanks
  • MarkMark Vanilla Staff
    That's an interesting problem. I've never run into that before - I guess because I manage all of my own servers.

    You can, of course, contact your hosting company and get them to chown the file back to you - then you can just chmod it so Vanilla can still work with it.
  • yeah I tried that but they didn't reply in the weekend - i just reinstalled the whole thing. It must be due to some overly protective security settings they have, but it's solved now. thanks for your kind help!
This discussion has been closed.