Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

IP History 1.0

blizeHblizeH ✭✭
edited July 2007 in Vanilla 1.0 Help
Just wondering... err, how exactly does this work? :)

Comments

  • Options
    MarkMark Vanilla Staff
    Did you read the readme.txt file that came with it?
  • Options
    blizeHblizeH ✭✭
    Yup, I have. I've got the application set to log IPs, and I've enabled the extension, I just can't find where to actually view the IP history.
  • Options
    lechlech Chicagoland
    edited July 2006
    haha, blizeh... if you ran vanilla pre 1.0 and in versions 0.9.x it was a feature you could see under every users profile. It turned up a nicely listed IP history for that user...

    ie: # 192.168.1.225 (2 times) This IP address has not been shared by any other users. 192.168.1.220 (12 times) This IP address has not been shared by any other users.

    it's a simple tool in aiding who could be using duplicate accounts on your forum.
  • Options
    blizeHblizeH ✭✭
    Ahh I see it now, sorry about that! I never knew it was in the users accounts :)
  • Options
    so, why doesn't it work with vanilla 1.0.1 ? or does it? It won't work for me. I've tried dissabling all other extensions. I did manage to make it KIND OF work. I copied the extension into accountprofile.php (in a theme folder) and It looked just like it used to in 1pre, except it wasnt able to find any IP addresses. It said something along the lines of 'It does not appear that this user has any IPs logged". I checked the SQL database and it is logging them. So I thought that it meant that the referance TO the data was invalid. I tried changing IpHistory in the database config to LUM_IpHistory, which as it turns out, it was already doing.
  • Options
    sorry for the double post, but i don't want to create another thread either. I'm having new problems with the IPhistory extension Does it still work with 1.0.3? I installed the new IPhistory 1.0.1 (not to be confused with the vanilla version) to get it to work again, but that failed I AM following instructions, like i should. I have log_all_ips 1, and double checked in the applications settings In case you were wondering, i stripped out all the "hack" that I did. (which actually never worked, so I did it a very long time ago)
  • Options
    wow, when i try to use my entire forum goes away poof
  • Options
    1.0 worked though
  • Options
    edited February 2007
    I was able to get 1.0 to work in pre vanilla 1.0, so it did work at one time.
  • Options
    IP History 1.0 works fine for me in 1.0.3 with or without a whole bunch of other extensions enabled as well... I would say it's more likely to be some kind of extension conflict or even a server setup issue.
  • Options
    I have more specific information: The database is keeping track of the IPs, but never user ID's. Every IP has a UserID value is always 0. let me know what else you need to know
  • Options
    are you the only person useing your site ? if thats the case its working.
  • Options
    No it aint cause noones user id is 0. Something's messed up somewhere..have you tried re-downloading the extension recently?
  • Options
    Yes i have re downloaded and updated it recently, but the file sizes were the same and it didn't fix anything. I doubt that this is the case, but I believe that it may have something to do with the Google Analytics extension that I have installed. Its either that, or it has something to do with the server. I really doubt that something is broken with the extension. Its worked in the past. It almost has to be an issue with another extension.
  • Options
    You tried disabling google analytics to see if it starts working properly after..?
  • Options
    It turns out that it was already disabled.
  • Options
    I see. So is the extension adding new IPs to the database when you get guests/users with new ips/whatever? And it just doesnt put the right user id in?
  • Options
    Yes. It seems like its treating the users as guests. Every ID is 0. Thats what the database reads. Theres more than 1000 entries and all of them have a 0 for the ID (sorry for the long delay)
  • Options
    MarkMark Vanilla Staff
    edited February 2007
    I've bookmarked this - I'll look into it when I can. Anyone else can feel free to do so as well - please post the fix if you find it.
  • Options
    edited July 2007
    A quick and possibly suboptimal solution is to do the following with library/People/People.Class.Authenticator.php:

    1. In method GetIdentity(): comment out //$this->LogIp($UserID);
    2. In method Authenticate($Username, $Password, $PersistentSession): add if ($UserID > 0) { $this->LogIp($UserID); } just above: return $UserID;
    Seems to be working for me, at least for now.
This discussion has been closed.