Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

"Welcome to Vanilla" message won't disappear permanently

edited December 2007 in Vanilla 1.0 Help
Everytime I login, or return to the discussions screen the welcome to Vanilla message appears, even if I have clicked the "remove message".
Anyone hve any ideas on a permanent solution? POssibly servers settings wronmg somewhere?

Comments

  • Options
    figured it out, lost the server settings on the settings.php files when i added an extention!
  • Options
    MarkMark Vanilla Staff
    ooo. That's strange. Have you tried enabling and disabling extensions since then? Does it continue to mess up the permissions on the file?
  • Options
    lechlech Chicagoland
    Mark, sounds like the issue I was having with one of the pre-release/svn copies until I made sure it wrote out the proper entry to the config file.
  • Options
    i have the same problem, don't even have to log out, after you remove it and click the category again it will pop back there, doesn't seem to want to stay removed
  • Options
    Hi ! I am having the same problem since I moved my Vanilla 1.0 installation to another location and had to set up the application again using the upgrade utility . That's all I can say, I don't have any other clue.
  • Options
    MarkMark Vanilla Staff
    It's a permission problem. Vanilla is failing to save a value to your conf/settings.php file.
  • Options
    edited August 2006
    +.+ I would say the same, but 'apache' is running as user apache and conf/settings.php has read and write permissions for owner apache. I will check again i could be wrong. Edit: Bug solved ! Here is what I did : I changed owner for all Vanilla files to apache - before that it was set to root ..-, removed /conf/settings.php, extensions.php and database.php , and ran the upgrader again. Once done I signed in and was able to remove the welcome message permanently. Despite this successful action I still don't know exactly which file or directory was causing this, as apache/PHP/Vanilla was initially able to create the file, so I assume it had write permission. Wouldn't it ?
  • Options
    Re, I tried to reproduce this bug in many ways but It gave nothing. Maybe it is related to enabling/disabling some extensions as it was said before.
  • Options
    Would you also be able to fix this by modifying the htaccess file?
  • Options
    Sorry jimw I have no clue about htaccess files. What are they used for ?
  • Options
    I'm just learning but it's used to control access to your files. You can have one in each of your folders on your server. There was another discussion here or on the WordPress support forum about MOD_REWRITE. Something was upgrade on my server which stopped me from adding posts and editing plugin files. So, I implemented what was suggested to the htaccess in certain folders. Then I had the same problem in Vanilla. So, I did the same thing. It seemed to do the trick. Maybe that is not the best way to fix the problem (I don't know), but it worked. Mark would probably have a better explanation.
  • Options
    Judging by the date of this thread I suppose this issue has been solved. I was having the same issue with the message coming up, followed the adivce here but still nothing. So I changed the following in the index.php file from $HideNotice = ForceIncomingBool('TurnOffAddonNotice', 0); to $HideNotice = ForceIncomingBool('TurnOffAddonNotice', 1); and also $SettingsManager->DefineSetting("ADDON_NOTICE", '0', 1); to $SettingsManager->DefineSetting("ADDON_NOTICE", '1', 1); Not sure of both or either of these changes did the trick, but it worked for me! Just thought I'd offer my 2 cents worth...
  • Options
    I was also having this problem after moving a Vanilla 1.1.4 forum to a new webserver. I set all the files in /conf to 777 and it still would not work, I manually added the following line to conf/settings.php and it worked:

    $Configuration['ADDON_NOTICE'] = '0';
This discussion has been closed.