Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Installing vanilla inside the sub-directory of the sub-domain! Help required

raguragu New
edited January 2014 in Vanilla 2.0 - 2.8

Let me put the steps I tried and how I wanted to:

I wanted to create multiple forum for different language, so I created en.mydomain.in for English, for the other language for example, french, I would create fr.mydomain.in

So my preference is to place the forum package inside the sub-directory of the subdomain

i.e en.mydomain.in/forum

This has to be my root for vanilla forum, in future If I add wordpress / blog, I prefer en.mydomain.com/blog

The conflicts I face, I use the shared hosting with cpanel.

mydomain.in is an add on domain, and created the sub-domain en.mydomain.in

I uploaded the vanilla 2.1b2 inside the root folder for en.mydomain.in, created the database. when I open the url first time, it opens for installation.

When I move the vanilla package to a sub-directory /forum i.e en.mydomain.in/forum and when I open the url for installation, it just stays blank and if I just type, en.mydomain.in, it browser displays /forum as directory.

Kindly assist me in setting up the forum inside the sub-directory of the sub-domain. Thanks

Best Answers

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    Answer ✓

    @ragu

    Welcome to the community.

    If you move a Vanilla install, you need to clear out the ini files (but not the folders) in the cache folder.

    hgtonightraguperegrine
  • peregrineperegrine MVP
    edited January 2014 Answer ✓

    sounds like your .htaccess file is not set properly. post your .htaccess file.

    make sure your rewrite base is set correctly. also you might want to use noindexes. and look at your logs to see where it tries to go and turn on debugging.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    hgtonightragu

Answers

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    Answer ✓

    @ragu

    Welcome to the community.

    If you move a Vanilla install, you need to clear out the ini files (but not the folders) in the cache folder.

    hgtonightraguperegrine
  • peregrineperegrine MVP
    edited January 2014 Answer ✓

    sounds like your .htaccess file is not set properly. post your .htaccess file.

    make sure your rewrite base is set correctly. also you might want to use noindexes. and look at your logs to see where it tries to go and turn on debugging.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    hgtonightragu
  • raguragu New
    edited January 2014

    Thanks @whu606 and @peregrine for your quick replies

    Clearing .ini solved the issue, i.e en.mydomain.in/forum, opens for installation but however the directory is displayed if I just get in to en.mydomain.in

    Reg .hta access, should I have to place it in the subdirectory where all my vanilla package is kept or in the root folder?

    Yes I don't want any indexes, do I have to redirect?

    UnderDog
Sign In or Register to comment.