Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Can't log in, problem in Firefox

edited September 2006 in Vanilla 1.0 Help
I'm not quite sure why this happened, whether it is a bug or what. After reading rockwaldo's discussion about the "remember me" cookie not working, (http://lussumo.com/community/discussion/2510/remember-me-still-doesnt-work-on-v1/#Item_31), I tested my own forum and found that I had the same problem. So I went ahead and double-checked my settings, and then I checked my cookies in Firefox and deleted the one for my forum (in case it was from an old install), closed all browser windows and then tried to log in again. "User / password combination does not exist." So I tried to have a password reminder sent to me. "User does not exist" So I went into phpMyAdmin and took a look at the tables and saw that the user name was still there. Very strange. Finally, since the system told me that the user does not exist, I tried signing up with the same username, and as you might guess, it wouldn't let me because the username is already taken. That's the basics of the problem in Firefox. I can log in okay in (cringe) IE. For the record I'm using a clean installation of version 1 (official release). Any thoughts? Ideas? What the heck did I break?

Comments

  • Options
    MarkMark Vanilla Staff
    edited July 2006
    If you are on a Windows server and you are having the same problem, this quick fix might work for you. Open up library/People/People.Control.SignInForm.php and comment out lines 55 to 68 like this:

    /* $AutoRedirect = 1; if ($this->Context->Session->User->Permission('PERMISSION_APPROVE_APPLICANTS')) { $this->ApplicantCount = $UserManager->GetApplicantCount(); if ($this->ApplicantCount > 0) $AutoRedirect = 0; } if ($this->ReturnUrl == '') { $this->ReturnUrl = $this->Context->Configuration['FORWARD_VALIDATED_USER_URL']; } else { $this->ReturnUrl = str_replace('&', '&', $this->ReturnUrl); } if ($AutoRedirect && $this->ReturnUrl != '') { header('location: '.$this->ReturnUrl); // die(); } */

    Then when you sign in, it won't attempt to redirect you - instead you should be presented with the "you have been signed in successfully" message and offer links to the forum. It's not the optimal solution since it doesn't kick you to the discussions right away - but at least it gets you back into the forum.

    If that doesn't work, get back to us and let us know what happened.
  • Options
    OMFG I am a bloody idiot. Never mind....you may want to delete this thread! What happened was Firefox was auto-filling the username and somewhere along the line I must have added an extra space. I should have noticed that. Did I mention I'm a moron? I'm really, really sorry for making you go to the trouble of coming up with a possible solution when the cause of the problem was entirely my fault. A thousand apologies!
  • Options
    edited September 2006
    on mac my firefox is not even accepting login username/password, is this odd or what ? doh!! i peeked at the x at the bottom of the browser and it was set on block, one of the problems with having too many plugins for firefox hard to keep tabs on all of them ;-) all back to normal
This discussion has been closed.