Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

show all users?

edited July 2006 in Vanilla 1.0 Help
Hi, I'm using the vanilla system for a fairly small group of people and think it would be cool to have a list of members available somewhere on the site, preferably with links to their profile pages. I didn't see any add-on for that (might be that I'm missing it). Any suggestions?

Comments

  • Options
    A user search with no search text will return a list of all members. You could do something that tied into that.
  • Options
    remoukremouk New
    edited July 2006
    Exact. If you are lazy you can just link to that page: http://yourvanillaforum.comnetorg/search/?PostBackAction=Search&Keywords=&Type=Users&btnSubmit=Search
  • Options
    ah allright - thanks! that's enough for now (although a nice dislay list on the left side might be cool!)
  • Options
    I've added this line to my .htaccess file - works very nicely:

    RewriteRule ^users/?$ search.php?PostBackAction=Search&Type=Users [QSA,L]

    Then you can just use the url yourforum.com/users
  • Options
    is that the .htaccess file in appg? mine looks like this: <Limit GET POST PUT> Order Allow,Deny Deny from All </Limit> where should I add it?
  • Options
    no its not, its the .htaccess in your root folder of vanilla.
  • Options
    do I have to add that file then, because in my install (latest version) there is no .htaccess in that folder...?
  • Options
    well loook on ftp if theres one already there if not then yes make one and add that.
  • Options
    allright, did that. should it be available as myurl.com/vanilla/users now? - if so, it isn't working (i have the vanilla set up in that dir) thanks for your help in any case, very nice!
  • Options
    err can i have the full url to your board?
  • Options
    here you are: http://www.zeptonn.nl/vanilla/
  • Options
    have you installed the FriendlyUrls extension and mod_rewrite enabled on your server?

    for me it's working: http://void-systems.net.tc/users/
  • Options
    ah no, I didn't do that - thanks!
This discussion has been closed.