Please upgrade here. These earlier versions are no longer being updated and have security issues.

(port 587=> SMTP Error: Could not authenticate) AND (port 465=> Language string failed to load: tls)

This discussion is related to the Contact addon.
RobenRoben New
edited January 2014 in Vanilla 2.0 - 2.3

Using google as outgoing mail server following this instruction: https://support.google.com/mail/troubleshooter/1668960?rd=1#ts=1665018,1665144

If I set the port field for 587 on TLS, when I try to send an email via this addon I get this error: SMTP Error: Could not authenticate

When I change the port to 465 on TLS, I get a different error: Language string failed to load: tls

When I change the port to 465 on SSL, I get a different error: SMTP Error: Could not authenticate

and for port 25 on SSL: SMTP Error: Could not connect to SMTP host.

Quote from google documentations:

Still can't send mail?
If you tried configuring your SMTP server on port 465 (with SSL) and port 587 (with TLS), but are still having trouble sending mail, try configuring your SMTP to use port 25 (with SSL).
Apple Mail users: At times, Mail may misinterpret your SMTP server settings. If you currently have 'smtp.gmail.com:[email protected]' in the 'Outgoing Mail Server:' field of your settings, please try changing the field to 'smtp.gmail.com' and saving your settings.

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    As far as I know, Vanilla is using an external library for sending mails: phpmailer. So your problem is not "vanilla and google smtp" but "phpmailer and google".

    Searching for that brings some possible solutions for you:
    http://stackoverflow.com/questions/810669/unable-to-send-mail-through-google-smtp-with-phpmailer
    If you just have to prefix the server with "ssl" it would be best. If you have to configure your php.ini it might be not allowed if you are on a shared hosting server. But if you have to add something to the mailer object, you will need the help of some specialists.

    Does that comment help you? http://vanillaforums.org/discussion/comment/154290#Comment_154290


  • RobenRoben New
    edited January 2014

    Thanks for your reply; I'd like to enable it for TLS; the first link was about ssl and I tried it, didn't help and also your last link.

    There is 2 connecting direction from vanilla to Gmail:

    Vanilla setting -> Host/Server Setting -> Gmail setting

    How should I set each one?

  • I have used gmail with vanilla so know it works. What you want to test is you smtp server is setup.

    However google will likely silently block your mail eventually becuase it not a transaction mail service, and has a limit to the number you can send per day. It is not a good choice IMO.

    grep is your friend.

  • @x00 said:
    and has a limit to the number you can send per day. It is not a good choice IMO.

    I want to use it for contact form. it's less than 10 emails per months by users!

    @x00 said:
    I have used gmail with vanilla so know it works.

    TLS or SSL?

    @x00 said:
    What you want to test is you smtp server is setup.

    yep

    However google will likely silently block your mail eventually becuase it not a transaction mail service

    Blocking? How can I find that?!

  • I want to use it for contact form. it's less than 10 emails per months by users!

    That si fine so long as the pluign allows you to use a separate mail server. Do not use for the main mail server. If you have another mail server use that.

    @x00 said: I have used gmail with vanilla so know it works.

    one or other can't remember. It was a short lived experiment as gmail doesn't like to be used for this purpose.

    However google will likely silently block your mail eventually becuase it not a transaction mail service

    tricky mail not delivered. I'm not even sure if they give clues in the mail logs. I think the deliberately don't give any clues they aren't delivering, to confuse spammers.

    grep is your friend.

  • try this test script

    http://vanillaforums.org/discussion/comment/200094/#Comment_200094

    you will need to change it to suit your settings.

    grep is your friend.

  • Hi,

    Hope the issue have been resolved, if not kindly follow the below instructions.

    login to affected machine
    do telnet to the destination server using the 465 port number to check the server connectivity.

    For more information please visit the site http://www.waiz.in/emailclients.html
    Please replace your server instead of Gmail.

    Regards,
    Waiz.

Sign In or Register to comment.