Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Emoticon drop down not displaying when posting a New Discussion

meshugymeshugy Musician/Hacker ✭✭

For some reason the emoticon drop down menu is no longer displaying when posting a new discussion. It works fine when posting comments. I'm using Vanilla 2.1.b2 with emotify 2.0.5

It used to work fine and I'm not sure exactly when it changed, Any ideas what the problem may be? You can see the problem here: http://www.djangobooks.com/forum/post/discussion/

thanks....

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    I had that problem, in one of those copies the js with the emoticons is missing ...

    If you want I can search for the file and tell you which it is.

    One question, does the dropdown appear at all or is it transparent ?

  • meshugymeshugy Musician/Hacker ✭✭

    @vrijvlinder yes, if you could let me know what is missing I'd appreciate it greatly!

    The dropdown doesn't appear at all when posting a New Discussion. It works fine for comments.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    please compare this emotify.js with what you have with this one.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Here is the php file compare with that too please

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2014

    This the only version of Emotify I have ever gotten to work and I use it on all my installs including 2.1.

    here is the history behind it

    http://vanillaforums.org/discussion/21943/emotify-from-vanilla-plugin-bundle-vs-emotify-plugin-download

  • peregrineperegrine MVP
    edited January 2014

    for version 2.05 of plugin - I made this change and it seemed to work.

    not fully tested - but it does show the emoticon dropdown box, when starting a discussion now.

    try this change emotify.js - at the bottom

        from this
    
         emotify($('.CommentForm .TextBox'));
           $(document).bind('EditCommentFormLoaded', function(e, container) {
              emotify(container.find('.EditCommentForm .TextBox'));
           });
    
        to this:
    
          emotify($('.CommentForm .TextBox'));
           $(document).bind('EditCommentFormLoaded', function(e, container) {
              emotify(container.find('.EditCommentForm .TextBox'));
           });
    
     emotify($('.DiscussionForm .TextBox'));
       $(document).bind('EditDiscussionFormLoaded', function(e, container) {
          emotify(container.find('.EditDiscussionForm .TextBox'));
       });
    

    make sure you leave the final at the bottom of the plugin.

    });

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Yes that makes sense coz for him it shows in the comments , when mine did not work it was for both.

    For a second I thought it was deja vu all over again !

  • peregrineperegrine MVP
    edited January 2014

    @vrijvlinder said:

    For a second I thought it was deja vu all over again !

    you and yogi berra!

    @meshugy throws a curve, will it be a strike or a home run, only @meshugy can tell us.

    I was batting 1 for 1 in another discussion against @meshugy when he lobbed one in placeholder discussion.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • meshugymeshugy Musician/Hacker ✭✭

    @vrijvlinder thanks, that worked! I had to reorganize all the smilies, but now it everything is functioning correctly. You're the best!

  • meshugymeshugy Musician/Hacker ✭✭

    @peregrine thanks, I'll see if that change works.

  • meshugymeshugy Musician/Hacker ✭✭

    @peregrine home run! It works....

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2014

    Wow @peregrine this is the first time both of us have been correct in an unrelated way !!!

    gives you hi-five :)

  • peregrineperegrine MVP
    edited January 2014

    @vrijvlinder said:
    Wow peregrine this is the first time both of us have been correct in an unrelated way !!!

    gives you hi-five :)

    and who said miracles can't happen.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • tom762tom762 New
    edited June 2014

    I just ran into this problem but any solution from above doesn't seem to work.

    Here's my setup:

    • Vanilla 2.1
    • Emotify 2.0.5
    • Bootstrap theme
    • Button bar 1.6

    Emoticons do work if you type them manually, it's just the drop-down that's not appearing. It doesn't matter if starting discussion or adding comment.

    Changing to default theme makes no change.

    I just discovered drop-down works if using Cleditor (which I can't use because it doesn't work properly on mobile devices).

    It's probably some stupid glitch which I can't seem to find. Any ideas?

    _edit: Changing to default theme does make a change. It must be something with Bootstrap then. :/ Not sure how to fix it either... _

Sign In or Register to comment.