Please upgrade here. These earlier versions are no longer being updated and have security issues.

Can't get the profile pictures to show up?

This discussion is related to the User List addon.

I'm using a version of vanilla posted on github and I can't get the profile pictures to show up on the user list. Any help, please?

Comments

  • what version number of vanilla?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • peregrineperegrine MVP
    edited January 2014

    in vanilla 2.0.18.10

    there is not settings button for the plugin, settings are changed in the sidemenu.

    all you need to do is change the settings via the link in the dashboard on the left under addons. you will see userlist option.

    or modify these items in your config.php

    // UserList
        $Configuration['UserList']['Limit'] = '5';
        $Configuration['UserList']['Hide'] = FALSE;
        $Configuration['UserList']['Random'] = FALSE;
        $Configuration['UserList']['Photo'] = '1';
        $Configuration['UserList']['NoPhoto'] = FALSE;
        $Configuration['UserList']['Title'] = 'my member list';
        $Configuration['UserList']['ShowNumUsers'] = FALSE;
    

    I wouldn't recommend using this plugin as a model for creating other plugins for vanilla 2.1
    since it uses &$Sender and doesn't seem to use the common conventions for naming plugin parameters. At the same time the plugin works perfectly in 2.0.18/

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @peregrine said:
    in vanilla 2.0.18.10

    there is not settings button for the plugin, settings are changed in the sidemenu.

    all you need to do is change the settings via the link in the dashboard on the left under addons. you will see userlist option.

    or modify these items in your config.php

    // UserList
    $Configuration['UserList']['Limit'] = '5';
    $Configuration['UserList']['Hide'] = FALSE;
    $Configuration['UserList']['Random'] = FALSE;
    $Configuration['UserList']['Photo'] = '1';
    $Configuration['UserList']['NoPhoto'] = FALSE;
    $Configuration['UserList']['Title'] = 'my member list';
    $Configuration['UserList']['ShowNumUsers'] = FALSE;

    I wouldn't recommend using this plugin as a model for creating other plugins for vanilla 2.1
    since it uses &$Sender and doesn't seem to use the common conventions for naming plugin parameters. At the same time the plugin works perfectly in 2.0.18/

    I'm using version 2.2.4... I can't find config.php and the settings on the dashboard lead to a en empty page...

  • peregrineperegrine MVP
    edited January 2014

    I'm using version 2.2.4...

    I can't find config.php and the settings on the dashboard lead to a en empty page...

    this is exactly why you shouldn't be using vanilla 2.2.4 which is an alpha version/

    because you don't understand vanilla.

    I suggest you use 2.0.18.10

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @peregrine said:

    I would use the stable version but I need plenty of add-ons which don't work on it...

    peregrine
  • peregrineperegrine MVP
    edited January 2014

    @peachy said:

    I would use the stable version but I need plenty of add-ons which don't work on it...

    it still doesn't explain why you are not using the beta version. 2.1b2

    see the irony of it all with the discussion posted one position away from yours:

    http://vanillaforums.org/discussion/25887/shall-i-use-version-2-3-a1-for-proper-website-publishing-purpose#latest

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @peachy said:
    I would use the stable version but I need plenty of add-ons which don't work on it...

    Funny but I am not aware of absolutely any plugins or themes that have been certified to work with anything above 2.1.

    There are many plugins which are not yet compatible with anything higher.

    It just is not ready for production, just like the Tesla electric car. People want to get one even if it catches on fire....

Sign In or Register to comment.