Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

JsConnect Issues

YonderYonder New
edited February 2014 in Vanilla 2.0 - 2.8

In the long run i'm trying to integrate usercake with a forum. I have ended up here with vanilla because the ease of use the integration can be.

All i ever get is:

{"error":"invalid_request","message":"The client_id parameter is missing."}

I have googled and searched this forum but no real solutions pop up just questions.

I have took the index.php from the libraries and replaced the client id and secret with ones generated from the admin of vanilla. All i ever get in the admin backend is: Validation does not exist: regex.

I have tried using the full information from usercake, id, username, email. Same result.

I have no idea what i am doing wrong, it seemed so straightforward.

Any help is appreciated.

Forum Version: 2.0.18.10
Jsconnect Version: 1.4.1

Answers

  • Options
    peregrineperegrine MVP
    edited February 2014

    one suggestion would be to post the plugin version of jsconnect you use and the version of vanilla you use.

    another suggestion to help other users would be to go to the plugin in the add-ons section and re-ask your question. so it is associated withe the plugin.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    YonderYonder New
    edited February 2014

    @peregrine said:
    one suggestion would be to post the plugin version of jsconnect you use and the version of vanilla you use.

    Sorry about that, i should have mentioned i am brand new to vanilla so most current versions of both.

    Forum Version: 2.0.18.10
    Jsconnect Version: 1.4.1

    Is it possible to delete this question then since i have re asked it.

  • Options

    another suggestion to help other users would be to go to the plugin in the add-ons section and re-ask your question. by choosing ask question, so it is associated with the plugin.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

This discussion has been closed.