Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Cannot get started

edited July 2006 in Vanilla 1.0 Help
I have installed MySql databases before, I have the right version of MySql. I added a database called "vanilla" and a user with a password. Installing Vanilla for the first time I get this message... ---------------------------------------------------------------------- The database responded with the following message: Access denied for user: 'JoeV@srv8512.com.au' (Using password: YES) ---------------------------------------------------------------------- What's up? I tried changing passwords and a different user, still no go!

Comments

  • Options
    Hey Wanderer, Try re-entering you password. I got that same msg when I mistakingly typed the wrong one.
  • Options
    I have exactly the same problem. Anyone have any ideas? The password idea from shie was a no go for me.
  • Options
    MarkMark Vanilla Staff
    Are you sure you've entered the database host address correctly? 90% of the time it should be "localhost".
  • Options
    DB name entered correctly and is 'localhost'. All CHMOD permissions correct. I'm completely stumped as to why I can't get past stage one of install.
  • Options
    MarkMark Vanilla Staff
    If it were me, I'd try going straight to mysql and resetting the password on that user account to whatever I wanted it to be and then try installing again. You never know ... it may be something else due to a typo...
  • Options
    edited July 2006
    Well I checked everything, passwords, permissions etc. All Ok. Ran Installer.php Got: "The database responded with the following message: Access denied for user: '******@localhost' (Using password: YES)" Checked my spelling and input information and now get: "Vanilla seems to have been installed already. You will need to remove the conf/settings.php, conf/database.php files, and all database tables in order to run the installer utility again." I removed these files with the exception of the database as it is not created and then had another go. Same result.
  • Options
    MarkMark Vanilla Staff
    edited July 2006
    Try making a test script that connects to the database. Doing basic connection tests with mysql is pretty easy. Create a new blank text file called mysqltest.php and put this inside:

    <?php // Turn on all errors error_reporting(E_ALL); // Customize your database connection $Host = "Your MySQL Host Name"; $User = "Your MySQL Username"; $Password = "Your MySQL Password"; $Database = "Your MySQL database name"; // Open a database connection (you may see some errors here) $Connection = mysql_connect($Host, $User, $Password); // Attempt to select your database if ($Connection && !mysql_select_db($Database, $Connection)) echo("Failed to connect to the '".$Database."' database."); ?>



    Give that a go and see what happens.
  • Options
    I think I figured it out. Using Winrar not all files were being unpacked - I don't know why Used Stuffit, uploaded, did the installation as before and I now have Vanilla running. Thanks for you help
  • Options
    MarkMark Vanilla Staff
    Oh snap. I didn't see that one coming.
  • Options
    Fixed it! Instead of simply "localhost" for the database address I had the full URL. Maybe this should be a hint on the installation page?
  • Options
    MarkMark Vanilla Staff
    Nice! Glad you got it figured out. If you want to add it to the troubleshooting page (click the tab above), feel free to do so.
This discussion has been closed.