Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

New OAuth for Twitter Sign In

As many of you know, "" has been retired and "" is currently being used. However, many other changes have been recently made to the Twitter Sign In setup process.

Please help! I have been spending many weeks trying to set up Vanilla2.1b2 and have hit a dead end trying to set up the Twitter log in. I have a small Vanilla forum about African Tribes that I had to close two years ago due to being spammed to death. I am hoping that Vanilla 2 will offer better protection against spammers and allow me to succeed with this unique forum about the Tribes of Africa.

The Twitter Sign in just won't work and I am sure that I have set up the app on Twitter correctly per the instructions given by Vanilla. No matter what I do I still get the same error message "HTTP 403 Forbidden." Please help me correct this error and help resurrect this forum!


  • Options
    AdrianAdrian Wandering Spirit Montreal MVP

    Are you using the latest Twitter plugin from Github? Twitter forced all the endpoints to HTTPS, and the add-on has been updated. Open your class.twitter.plugin.php and make sure the following changes were made. Let us know if that fixes it.

  • Options

    Adrian, it worked like a charm! Thanks ever so much. The latest code for class.twitter.plugin.php is different from the code that was bundled in Vanilla2.1b2, so new users should beware.

    Now if I could get the Google login to work again, which was working but now seems to be on the "blink" due to problems at Google.

    On a side note, I found out the secret to installing the new Facebook login procedure. You need to change the Advanced options in the Settings tab at They allow you to add multiple "Valid OAuth redirect URIs" so I added seven different variations (with and without "www," "80," etc.) I even went so far as to add the "kitchen sink" (,publish_stream&display=popup) for the URI.

    In any case, I hope this info helps those who are struggling to add the Facebook and Twitter Sign In buttons. Thanks again Adrian, you're a gem!

  • Options
    edited March 2014

    How to make it work on vanilla The problem is same. The pop-up is saying SSL error. Changed
    public static $BaseApiUrl = '';
    public static $BaseApiUrl = '';

    Did not work

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    You should look at the code more clearly and make sure did not miss one.

  • Options

    Thanks for making me re-look. I had missed editing another line

Sign In or Register to comment.