Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Extensions are not being enabled

edited July 2006 in Vanilla 1.0 Help
I just downloaded several extensions to the extensions directory, went into the settings and checked the box to enable them, then went to test them out and the extensions did NOTHING. I then went back to the extension settings and ALL OF THE EXTENSIONS were NOT checked. There seems to be a missing 'submit' button on the extension setting page.. because there is no way to SAVE the checked boxes.... How do you tell Vanilla to keep the extensions CHECKED as in ENABLED?

Comments

  • Oh yeah I and I also installed 2 styles and put them in the correct directory and they fail to show up in the drop down style chooser.
  • I cleared my cache and history think that was the problem... Now I can't even login to my forum! I click on 'signin' and it just reloads the guest view of the forum!
  • Okay I fixed it... I deleted the appg and conf directories, then uploaded all the files again and redid the upgrade process... the extension problem seems to be fixed..
  • MarkMark Vanilla Staff
    edited July 2006
    It sounds like you had your permissions set up incorrectly.

    http://lussumo.com/docs/doku.php?id=vanilla:administrators:troubleshooting

    Regarding the styles dropdown, it could also be that php doesn't have read permission on that folder. What *does* show up in the dropdown?

    When you right-click the sign in button, choose copy link location to see where it is trying to send you.
  • vanilla and default show up on the style drop downs... thats it. the signin link in the upper right hand corner still doesn't work... but the other signin link does work...
  • And with 0.9.2 after I signed out the only page I would see is the login screen... now I see the forum (only without posts) and the upper right hand corner signin link doesn't do anything except refresh the page... this is upsetting because i want my forum private.. i dont want guests seeing the forum, even if they cant see the posts... i just want guests to see the LOGIN screen. THAT's IT.
  • lechlech Chicagoland
    First thing you're going to have to probably do is reset some if not most of your forum settings and build it up from scratch to what it was previously. Most of the admin panel options (which might looks slightly different) are still the same, you'll simply need to reset and tweak your settings and slowly pull extensions back into the fold one by one. Some portions which were once "core features" have been detached into their own extensions, however you should still get the same functionality you had before without them. I strongly suggest looking through Add-ons site and downloading all of mark's extensions, but make sure they're all updated for 1.0 and not any other version. Most should work, while 1 or 2 might still have some bugs, but overall, you should get the basic feel of 0.9.x back in there if you feel it's been missing.
  • I just deleted all my files and then uploaded everything again and installed... and I can still CANNOT login... I dont want to delete the database because I'll lose all the posts and such...
  • lechlech Chicagoland
    OK, lets do baby steps. 1. You uploaded all your files, paths and everything are correct. 2. Was anything written to your /conf/ folder? download the files from your server to a temporary folder and examine their contents, if everything looks alright, follow to the next step. 3. does your /conf/ folder have the proper permissions? it should have an elevated permission of 757 (default is 755) 4. do the files within the /conf/ folder have the correct permission settings? to make them writeable, you want them as 666 (default is 644) 5. did you link to another database which was empty? double check the database name along with user/pw settings, if you can directly look at your database, list what databases it contains which belong to you. 6. Remind me to update the wiki and call in jonezy for restraint and possible backup.
This discussion has been closed.