Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

how to change the domain associated with self hosted [solved]

epipenepipen New
edited February 2014 in Vanilla 2.0 - 2.8

When logging in to forums.domain.com - everything is fine until we try to login
1: login > enter credentials > page not found...
2: why? because forum.domain.com/blahblahblah (internet accessible dns entry) changes to forum/blahblahblah (internal dns entry) - see the following picture

imageImage and video hosting by TinyPic" alt="" />

or try this link if the above link doesn't work.
http://tinypic.com/r/282q934/8
I have grep searched everything and cannot seem to find the proper string to search. I have dumped the database and searched that as well. I need some assistance here so our forums can go live.

Comments

  • The image did not post properly - here it is manually uploaded.

  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff
    edited February 2014

    Open your conf/config.php file, do you see below? Have you modified?

    $Configuration['Garden']['Domain'] = ''; $Configuration['Garden']['WebRoot'] = FALSE; // You can set this value if you are using htaccess to direct into the application, but the correct webroot isn't being recognized.

  • epipenepipen New
    edited February 2014

    I have opened this but not modified it.
    this is what the "garden" section of the config file looks like
    the part in bold is the closest to what you have described. I see njo "web root" option.

    What would i need to do with this.
    what i have tried is setting
    $Configuration['Garden']['Cookie']['Domain'] = 'domain.com';
    $Configuration['Garden']['Cookie']['webroot'] = true;



    below is cut (and modified to protect the innocent) from the config file.



    // Garden

    $Configuration['Garden']['Cookie']['Domain'] = '';

    [removed]

  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff
    edited February 2014

    @epipen, sorry I have removed your sensitive info. You can add the item I have mentioned to your config

    Can you try:

    $Configuration['Garden']['Domain'] = 'yoursite.com';

  • instead of displaying forum.domain.com - it is still displaying forum/

  • Here are some more screen shots


    imageImage and video hosting by TinyPic" alt="" />

  • epipenepipen New
    edited February 2014

    Please note that i can MANUALLY correct the domain once i have logged in with my credentials, however, the application occasionally switches the link from a public domain address to a private domain address. This is not an issue when accessing from the intranet, but for our users accessing from the internet, they get a 404 error and do not know to manually fix the link (nor should they have to in a perfect world).

  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff

    Where are you hosting your site?

  • epipenepipen New
    edited February 2014

    SOLVED:

    The issue was not the vanilla forums. Our firewall forwarder has an option to pass through the originating url. If unchecked, the url get's translated locally.

    Image and video hosting by TinyPic

    Adrianhgtonight
  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff

    Glad it was resolved, thanks for letting us know

Sign In or Register to comment.