How to Use Vanilla with SSL

2»

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    you did buy an SSL certificate ? Please describe what you did exactly so I don't assume something untrue.

    ahmedaladdin
  • Yes, I purchased an SSL certificate and wordpress works perfect with it. I installed vanilla in a sub directory and followed the instructions of embedding vanilla ver. 2.1 core embed. Then tried embed plugin and disabled core embed but found the same result :(

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Make sure you also delete the ini files from the cache when ever you disable plugins or edit them. Did you try and use the zip up there a few comments above ? This works but you need to make sure you change all http to https also in the link to the js code for the embed if you embed the forum.

    did you add this to config.php ?

    $Configuration['Garden']['ForceSSL'] = TRUE;

    ahmedaladdin
  • Deleted the ini files now from cache folder
    I used your file, yes.
    There are 4 http changed to https in embed_local.js file, yes
    Yes, $Configuration['Garden']['ForceSSL'] = TRUE added earlier

    Still the same!!
    Is the wordpress embed URL shows "Couldn't find a Vanilla Forum at this url :/" ? I have this and couldn't really know how to solve it or is it the cause of this?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    there is no embed_local.js in the embed vanilla plugin only remote.js and local.js

    ahmedaladdin
  • Thats inside vanilla core embed files

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited July 2014

    I thought you said you used the zip up there, which is the embed vanilla plugin. That is different from the core plugin...As far as I am concerned you need to change the http to https on every file from the plugin or the core where there is http... everywhere not just one file. You need to look through all the embed files and change it. Or use the plugin from the zip ...

    ahmedaladdin
  • Yes i used it as embed plugin instead of core embed. I have also followed your instructions to try changing the core files but both didnt work

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    I can't tell the difference between the two. You have some kind or redirect going on. Forces the url below

    https://yoursite.com/pages/forum#

    You installed vanilla in a subfolder called forum? I don't see it because you have something redirecting to the embed which is also wrongly embedded.It is a loop of redirects.

    You need to sort that out or it is impossible to know what is going on. First get the stand alone forum to work then deal with embed.

    ahmedaladdin
  • Disabled the redirection. It was enabled through the vanilla embed itself " Force the forum to only be accessible through this url"

  • Thank you so so so much @vrijvlinder for your extreme support!!

    You have offered me 2 solutions to overcome this problem and guided me through the root cause of this problem. I would hereby share my experience with it with others, hope I do it well:

    If you wish to configure vanilla to work with https, simply download @vrijvlinder zip file posted up in this discussion. Then make sure your wordpress doesn't run any minify plugin as advised by @vrijvlinder‌.

    This will make your vanilla embedded without any issues. The alternative way is to use iframe methohd.

    Very special thanks for @vrijvlinder support,

    vrijvlinder
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    VrijVlinder , saint of the minified obscurity cases...

    peregrine
  • @x00 said:
    It shows a blank page becuase of mixed content.

    You have to make a change to the embed script. Are using plugins/embedvanilla/remote.js? Or the the core one?

    It is basically a case of changing the http to https in the script.

    Could someone ELI5 what file I need to edit & with what line replacing what line to make ssl controllers work? Right now I click the 'enable' button but it stays at 'disabled'.

    Thanks,

    -N

  • @NginUS said:
    Could someone ELI5 what file I need to edit & with what line replacing what line to make ssl controllers work? Right now I click the 'enable' button but it stays at 'disabled'.

    This is a different question

    grep is your friend.

2»
Sign In or Register to comment.